aboutsummaryrefslogtreecommitdiff
path: root/src/regex/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-05-22 12:03:07 +0000
committerChristian Grothoff <christian@grothoff.org>2015-05-22 12:03:07 +0000
commit157f7872646546aa956e36b3c3629eed00013f45 (patch)
tree312a4a7d6cb364b231113b7011e64c5dc27b86e6 /src/regex/Makefile.am
parentf1593742051929aea7f86175b4af11ef45f3d481 (diff)
downloadgnunet-157f7872646546aa956e36b3c3629eed00013f45.tar.gz
gnunet-157f7872646546aa956e36b3c3629eed00013f45.zip
-adding integration test
Diffstat (limited to 'src/regex/Makefile.am')
-rw-r--r--src/regex/Makefile.am23
1 files changed, 16 insertions, 7 deletions
diff --git a/src/regex/Makefile.am b/src/regex/Makefile.am
index 78324042d..43555cf72 100644
--- a/src/regex/Makefile.am
+++ b/src/regex/Makefile.am
@@ -31,7 +31,7 @@ gnunet_service_regex_LDADD = -lm \
31 $(top_builddir)/src/dht/libgnunetdht.la \ 31 $(top_builddir)/src/dht/libgnunetdht.la \
32 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 32 $(top_builddir)/src/statistics/libgnunetstatistics.la \
33 $(top_builddir)/src/util/libgnunetutil.la \ 33 $(top_builddir)/src/util/libgnunetutil.la \
34 $(GN_LIBINTL) 34 $(GN_LIBINTL)
35 35
36noinst_LIBRARIES = \ 36noinst_LIBRARIES = \
37 libgnunetregex_internal.a \ 37 libgnunetregex_internal.a \
@@ -64,7 +64,7 @@ libgnunetregex_internal_a_DEPENDENCIES = \
64libgnunetregex_la_SOURCES = \ 64libgnunetregex_la_SOURCES = \
65 regex_api.c regex_ipc.h 65 regex_api.c regex_ipc.h
66libgnunetregex_la_LIBADD = \ 66libgnunetregex_la_LIBADD = \
67 $(top_builddir)/src/util/libgnunetutil.la 67 $(top_builddir)/src/util/libgnunetutil.la
68libgnunetregex_la_LDFLAGS = \ 68libgnunetregex_la_LDFLAGS = \
69 $(GN_LIB_LDFLAGS) \ 69 $(GN_LIB_LDFLAGS) \
70 -version-info 3:1:0 70 -version-info 3:1:0
@@ -92,13 +92,13 @@ gnunet_regex_simulation_profiler_LDADD = \
92 $(top_builddir)/src/util/libgnunetutil.la \ 92 $(top_builddir)/src/util/libgnunetutil.la \
93 libgnunetregex_internal.a \ 93 libgnunetregex_internal.a \
94 $(top_builddir)/src/dht/libgnunetdht.la \ 94 $(top_builddir)/src/dht/libgnunetdht.la \
95 $(top_builddir)/src/mysql/libgnunetmysql.la 95 $(top_builddir)/src/mysql/libgnunetmysql.la
96endif 96endif
97 97
98libgnunetregextest_a_SOURCES = \ 98libgnunetregextest_a_SOURCES = \
99 regex_test_lib.c regex_test_lib.h \ 99 regex_test_lib.c regex_test_lib.h \
100 regex_test_graph.c \ 100 regex_test_graph.c \
101 regex_test_random.c 101 regex_test_random.c
102libgnunetregextest_a_LIBADD = \ 102libgnunetregextest_a_LIBADD = \
103 $(top_builddir)/src/util/libgnunetutil.la \ 103 $(top_builddir)/src/util/libgnunetutil.la \
104 libgnunetregex_internal.a 104 libgnunetregex_internal.a
@@ -116,7 +116,7 @@ perf_regex_LDADD = -lm \
116 $(top_builddir)/src/dht/libgnunetdht.la \ 116 $(top_builddir)/src/dht/libgnunetdht.la \
117 libgnunetregexblock.la \ 117 libgnunetregexblock.la \
118 libgnunetregextest.a \ 118 libgnunetregextest.a \
119 $(top_builddir)/src/util/libgnunetutil.la 119 $(top_builddir)/src/util/libgnunetutil.la
120 120
121gnunet_regex_profiler_SOURCES = \ 121gnunet_regex_profiler_SOURCES = \
122 gnunet-regex-profiler.c 122 gnunet-regex-profiler.c
@@ -128,7 +128,7 @@ gnunet_regex_profiler_LDADD = -lm \
128 libgnunetregexblock.la \ 128 libgnunetregexblock.la \
129 libgnunetregextest.a \ 129 libgnunetregextest.a \
130 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 130 $(top_builddir)/src/statistics/libgnunetstatistics.la \
131 $(top_builddir)/src/util/libgnunetutil.la 131 $(top_builddir)/src/util/libgnunetutil.la
132 132
133gnunet_daemon_regexprofiler_SOURCES = \ 133gnunet_daemon_regexprofiler_SOURCES = \
134 gnunet-daemon-regexprofiler.c 134 gnunet-daemon-regexprofiler.c
@@ -138,9 +138,10 @@ gnunet_daemon_regexprofiler_LDADD = -lm \
138 libgnunetregexblock.la \ 138 libgnunetregexblock.la \
139 libgnunetregextest.a \ 139 libgnunetregextest.a \
140 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 140 $(top_builddir)/src/statistics/libgnunetstatistics.la \
141 $(top_builddir)/src/util/libgnunetutil.la 141 $(top_builddir)/src/util/libgnunetutil.la
142 142
143check_PROGRAMS = \ 143check_PROGRAMS = \
144 test_regex_integration \
144 test_regex_eval_api \ 145 test_regex_eval_api \
145 test_regex_iterate_api \ 146 test_regex_iterate_api \
146 test_regex_proofs \ 147 test_regex_proofs \
@@ -161,6 +162,14 @@ test_regex_eval_api_LDADD = -lm \
161 libgnunetregexblock.la \ 162 libgnunetregexblock.la \
162 $(top_builddir)/src/util/libgnunetutil.la 163 $(top_builddir)/src/util/libgnunetutil.la
163 164
165test_regex_integration_SOURCES = \
166 test_regex_integration.c
167test_regex_integration_LDADD = -lm \
168 libgnunetregex.la \
169 $(top_builddir)/src/testing/libgnunettesting.la \
170 $(top_builddir)/src/tun/libgnunettun.la \
171 $(top_builddir)/src/util/libgnunetutil.la
172
164test_regex_api_SOURCES = \ 173test_regex_api_SOURCES = \
165 test_regex_api.c 174 test_regex_api.c
166test_regex_api_LDADD = -lm \ 175test_regex_api_LDADD = -lm \