aboutsummaryrefslogtreecommitdiff
path: root/src/regex/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-06-20 08:55:56 +0000
committerChristian Grothoff <christian@grothoff.org>2013-06-20 08:55:56 +0000
commit5f7a6c8f6816a826a2dd93eadc5039733f7db606 (patch)
tree3c22c8ff3436cc3140dfb1b24813ed4362330879 /src/regex/Makefile.am
parent21a2b4f95b4488645ba5a6254fcb8919c4915f73 (diff)
downloadgnunet-5f7a6c8f6816a826a2dd93eadc5039733f7db606.tar.gz
gnunet-5f7a6c8f6816a826a2dd93eadc5039733f7db606.zip
moving functions for testing and evaluation and experiments to the test library, minimizing the internal library, renaming files according to which library they belong to
Diffstat (limited to 'src/regex/Makefile.am')
-rw-r--r--src/regex/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/src/regex/Makefile.am b/src/regex/Makefile.am
index 6e6fd443a..34ef90ca0 100644
--- a/src/regex/Makefile.am
+++ b/src/regex/Makefile.am
@@ -55,9 +55,9 @@ libgnunetregexblock_la_LDFLAGS = \
55 55
56 56
57libgnunetregex_internal_a_SOURCES = \ 57libgnunetregex_internal_a_SOURCES = \
58 regex_internal.h regex.c \ 58 regex_internal_lib.h \
59 regex_graph.c regex_random.c \ 59 regex_internal.h regex_internal.c \
60 regex_dht.c 60 regex_internal_dht.c
61libgnunetregex_internal_a_DEPENDENCIES = \ 61libgnunetregex_internal_a_DEPENDENCIES = \
62 libgnunetregexblock.la 62 libgnunetregexblock.la
63 63
@@ -100,7 +100,9 @@ gnunet_regex_simulation_profiler_DEPENDENCIES = \
100endif 100endif
101 101
102libgnunetregextest_a_SOURCES = \ 102libgnunetregextest_a_SOURCES = \
103 regex_test_lib.c regex_test_lib.h 103 regex_test_lib.c regex_test_lib.h \
104 regex_test_graph.c \
105 regex_test_random.c
104libgnunetregextest_a_LIBADD = \ 106libgnunetregextest_a_LIBADD = \
105 $(top_builddir)/src/util/libgnunetutil.la \ 107 $(top_builddir)/src/util/libgnunetutil.la \
106 $(top_builddir)/src/regex/libgnunetregex_internal.a 108 $(top_builddir)/src/regex/libgnunetregex_internal.a
@@ -172,6 +174,7 @@ test_regex_eval_api_SOURCES = \
172 test_regex_eval_api.c 174 test_regex_eval_api.c
173test_regex_eval_api_LDADD = -lm \ 175test_regex_eval_api_LDADD = -lm \
174 $(top_builddir)/src/regex/libgnunetregex_internal.a \ 176 $(top_builddir)/src/regex/libgnunetregex_internal.a \
177 $(top_builddir)/src/regex/libgnunetregextest.a \
175 $(top_builddir)/src/regex/libgnunetregexblock.la \ 178 $(top_builddir)/src/regex/libgnunetregexblock.la \
176 $(top_builddir)/src/util/libgnunetutil.la 179 $(top_builddir)/src/util/libgnunetutil.la
177 180
@@ -186,6 +189,7 @@ test_regex_proofs_SOURCES = \
186 test_regex_proofs.c 189 test_regex_proofs.c
187test_regex_proofs_LDADD = -lm \ 190test_regex_proofs_LDADD = -lm \
188 $(top_builddir)/src/regex/libgnunetregex_internal.a \ 191 $(top_builddir)/src/regex/libgnunetregex_internal.a \
192 $(top_builddir)/src/regex/libgnunetregextest.a \
189 $(top_builddir)/src/regex/libgnunetregexblock.la \ 193 $(top_builddir)/src/regex/libgnunetregexblock.la \
190 $(top_builddir)/src/util/libgnunetutil.la 194 $(top_builddir)/src/util/libgnunetutil.la
191 195
@@ -193,6 +197,7 @@ test_regex_graph_api_SOURCES = \
193 test_regex_graph_api.c 197 test_regex_graph_api.c
194test_regex_graph_api_LDADD = -lm \ 198test_regex_graph_api_LDADD = -lm \
195 $(top_builddir)/src/regex/libgnunetregex_internal.a \ 199 $(top_builddir)/src/regex/libgnunetregex_internal.a \
200 $(top_builddir)/src/regex/libgnunetregextest.a \
196 $(top_builddir)/src/regex/libgnunetregexblock.la \ 201 $(top_builddir)/src/regex/libgnunetregexblock.la \
197 $(top_builddir)/src/util/libgnunetutil.la 202 $(top_builddir)/src/util/libgnunetutil.la
198 203