aboutsummaryrefslogtreecommitdiff
path: root/src/regex/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-05-31 16:27:42 +0000
committerChristian Grothoff <christian@grothoff.org>2013-05-31 16:27:42 +0000
commit6b8e5711bd0a93296ef9a22602e72c34df5415a4 (patch)
tree36f96c755201e25d76da9b7dd993459523ee1c69 /src/regex/Makefile.am
parent8590cba90ab53a070d5ce3d8ec8f1a7f4fb4ee23 (diff)
downloadgnunet-6b8e5711bd0a93296ef9a22602e72c34df5415a4.tar.gz
gnunet-6b8e5711bd0a93296ef9a22602e72c34df5415a4.zip
-skeleton for regex service
Diffstat (limited to 'src/regex/Makefile.am')
-rw-r--r--src/regex/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/regex/Makefile.am b/src/regex/Makefile.am
index e88938054..f57b78611 100644
--- a/src/regex/Makefile.am
+++ b/src/regex/Makefile.am
@@ -8,6 +8,32 @@ if USE_COVERAGE
8 AM_CFLAGS = --coverage 8 AM_CFLAGS = --coverage
9endif 9endif
10 10
11pkgcfgdir= $(pkgdatadir)/config.d/
12
13libexecdir= $(pkglibdir)/libexec/
14
15plugindir = $(libdir)/gnunet
16
17pkgcfg_DATA = \
18 regex.conf
19
20libexec_PROGRAMS = \
21 gnunet-service-regex
22
23gnunet_service_regex_SOURCES = \
24 gnunet-service-regex.c
25gnunet_service_regex_LDADD = \
26 $(top_builddir)/src/regex/libgnunetregex.la \
27 $(top_builddir)/src/dht/libgnunetdht.la \
28 $(top_builddir)/src/statistics/libgnunetstatistics.la \
29 $(top_builddir)/src/util/libgnunetutil.la \
30 $(GN_LIBINTL)
31gnunet_service_regex_DEPENDENCIES = \
32 libgnunetregex.la
33# todo: link files from libgnunetregex statically into gnunet_service_regex,
34# rename API prefix to avoid collision with 'libgnunetregexnew'...
35
36# FIXME: shouldn't the block library be in the plugin directory!?
11lib_LTLIBRARIES = libgnunetregexblock.la \ 37lib_LTLIBRARIES = libgnunetregexblock.la \
12 libgnunetregex.la \ 38 libgnunetregex.la \
13 libgnunetregexnew.la 39 libgnunetregexnew.la