aboutsummaryrefslogtreecommitdiff
path: root/src/regex/Makefile.am
diff options
context:
space:
mode:
authorMaximilian Szengel <gnunet@maxsz.de>2012-10-15 17:06:17 +0000
committerMaximilian Szengel <gnunet@maxsz.de>2012-10-15 17:06:17 +0000
commit0cbfe4d4b98355087c387124e6b852d06093a26e (patch)
tree8940b0c23afcc8138b0d13279f775fca6036f3cc /src/regex/Makefile.am
parent745f5b00bd774fc723b644ccbea4284f5ac00771 (diff)
downloadgnunet-0cbfe4d4b98355087c387124e6b852d06093a26e.tar.gz
gnunet-0cbfe4d4b98355087c387124e6b852d06093a26e.zip
renamed test_regex_big / fixes
Diffstat (limited to 'src/regex/Makefile.am')
-rw-r--r--src/regex/Makefile.am77
1 files changed, 38 insertions, 39 deletions
diff --git a/src/regex/Makefile.am b/src/regex/Makefile.am
index 2919e4da9..9824db522 100644
--- a/src/regex/Makefile.am
+++ b/src/regex/Makefile.am
@@ -14,65 +14,64 @@ libgnunetregex_la_SOURCES = \
14 regex_internal.h regex.c \ 14 regex_internal.h regex.c \
15 regex_graph.c regex_random.c 15 regex_graph.c regex_random.c
16libgnunetregex_la_LIBADD = -lm \ 16libgnunetregex_la_LIBADD = -lm \
17 $(top_builddir)/src/util/libgnunetutil.la 17 $(top_builddir)/src/util/libgnunetutil.la
18libgnunetregex_la_LDFLAGS = \ 18libgnunetregex_la_LDFLAGS = \
19 $(GN_LIB_LDFLAGS) \ 19 $(GN_LIB_LDFLAGS) \
20 -version-info 0:0:0 20 -version-info 0:0:0
21 21
22check_PROGRAMS = \ 22noinst_PROGRAMS = \
23 test_regex_eval_api \ 23 gnunet-regex-profiler
24 test_regex_iterate_api \ 24
25 test_regex_proofs \ 25gnunet_regex_profiler_SOURCES = \
26 test_regex_graph_api \ 26 gnunet-regex-profiler.c
27 test_regex_iptoregex \ 27gnunet_regex_profiler_LDADD = \
28 test_regex_big 28 $(top_builddir)/src/regex/libgnunetregex.la \
29 $(top_builddir)/src/util/libgnunetutil.la \
30 $(top_builddir)/src/testbed/libgnunettestbed.la
31gnunet_regex_profiler_DEPENDENCIES = \
32 libgnunetregex.la
29 33
34check_PROGRAMS = \
35 test_regex_eval_api \
36 test_regex_iterate_api \
37 test_regex_proofs \
38 test_regex_graph_api \
39 test_regex_iptoregex
30 40
31if ENABLE_TEST_RUN 41if ENABLE_TEST_RUN
32TESTS = \ 42 TESTS = $(check_PROGRAMS)
33 test_regex_eval_api \
34 test_regex_iterate_api \
35 test_regex_proofs \
36 test_regex_graph_api
37endif 43endif
38 44
39test_regex_eval_api_SOURCES = \ 45test_regex_eval_api_SOURCES = \
40 test_regex_eval_api.c 46 test_regex_eval_api.c
41test_regex_eval_api_LDADD = \ 47test_regex_eval_api_LDADD = \
42 $(top_builddir)/src/regex/libgnunetregex.la \ 48 $(top_builddir)/src/regex/libgnunetregex.la \
43 $(top_builddir)/src/util/libgnunetutil.la 49 $(top_builddir)/src/util/libgnunetutil.la
44 50
45test_regex_iterate_api_SOURCES = \ 51test_regex_iterate_api_SOURCES = \
46 test_regex_iterate_api.c 52 test_regex_iterate_api.c
47test_regex_iterate_api_LDADD = \ 53test_regex_iterate_api_LDADD = \
48 $(top_builddir)/src/regex/libgnunetregex.la \ 54 $(top_builddir)/src/regex/libgnunetregex.la \
49 $(top_builddir)/src/util/libgnunetutil.la 55 $(top_builddir)/src/util/libgnunetutil.la
50 56
51test_regex_proofs_SOURCES = \ 57test_regex_proofs_SOURCES = \
52 test_regex_proofs.c 58 test_regex_proofs.c
53test_regex_proofs_LDADD = \ 59test_regex_proofs_LDADD = \
54 $(top_builddir)/src/regex/libgnunetregex.la \ 60 $(top_builddir)/src/regex/libgnunetregex.la \
55 $(top_builddir)/src/util/libgnunetutil.la 61 $(top_builddir)/src/util/libgnunetutil.la
56 62
57test_regex_graph_api_SOURCES = \ 63test_regex_graph_api_SOURCES = \
58test_regex_graph_api.c 64 test_regex_graph_api.c
59test_regex_graph_api_LDADD = \ 65test_regex_graph_api_LDADD = \
60$(top_builddir)/src/regex/libgnunetregex.la \ 66 $(top_builddir)/src/regex/libgnunetregex.la \
61$(top_builddir)/src/util/libgnunetutil.la 67 $(top_builddir)/src/util/libgnunetutil.la
62
63test_regex_big_SOURCES = \
64test_regex_big.c
65test_regex_big_LDADD = \
66 $(top_builddir)/src/regex/libgnunetregex.la \
67 $(top_builddir)/src/util/libgnunetutil.la \
68 $(top_builddir)/src/testbed/libgnunettestbed.la
69 68
70test_regex_iptoregex_SOURCES = \ 69test_regex_iptoregex_SOURCES = \
71test_regex_iptoregex.c 70 test_regex_iptoregex.c
72test_regex_iptoregex_LDADD = \ 71test_regex_iptoregex_LDADD = \
73 $(top_builddir)/src/util/libgnunetutil.la \ 72 $(top_builddir)/src/util/libgnunetutil.la \
74 $(top_builddir)/src/regex/libgnunetregex.la 73 $(top_builddir)/src/regex/libgnunetregex.la
75 74
76 75
77EXTRA_DIST = 76EXTRA_DIST = \
78# test_regex_data.conf 77 regex_profiler_test.conf