summaryrefslogtreecommitdiff
path: root/src/regex/Makefile.am
diff options
context:
space:
mode:
authorBart Polot <bart@net.in.tum.de>2013-01-17 17:09:37 +0000
committerBart Polot <bart@net.in.tum.de>2013-01-17 17:09:37 +0000
commit47cb85c43071a16ec899e7f8fb45b3eec39895ec (patch)
tree4b3ec6dd6eb72488826053d0ce9fc45d26df3df6 /src/regex/Makefile.am
parent37a8306064f1fe08c1471c46a3cd913cd22f8a60 (diff)
downloadgnunet-47cb85c43071a16ec899e7f8fb45b3eec39895ec.tar.gz
gnunet-47cb85c43071a16ec899e7f8fb45b3eec39895ec.zip
Move regex DHT integration from mesh to regex
Diffstat (limited to 'src/regex/Makefile.am')
-rw-r--r--src/regex/Makefile.am42
1 files changed, 39 insertions, 3 deletions
diff --git a/src/regex/Makefile.am b/src/regex/Makefile.am
index f6ab33abf..7d7c84dfe 100644
--- a/src/regex/Makefile.am
+++ b/src/regex/Makefile.am
@@ -8,17 +8,53 @@ if USE_COVERAGE
8 AM_CFLAGS = --coverage 8 AM_CFLAGS = --coverage
9endif 9endif
10 10
11lib_LTLIBRARIES = libgnunetregex.la 11lib_LTLIBRARIES = libgnunetregexblock.la \
12 libgnunetregex.la
13
14
15libgnunetregexblock_la_SOURCES = \
16 regex_block_lib.c regex_block_lib.h
17libgnunetregexblock_la_LIBADD = \
18 $(top_builddir)/src/util/libgnunetutil.la \
19 $(XLIB) \
20 $(LTLIBINTL)
21libgnunetregexblock_la_LDFLAGS = \
22 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
23 -version-info 1:0:0
12 24
13libgnunetregex_la_SOURCES = \ 25libgnunetregex_la_SOURCES = \
14 regex_internal.h regex.c \ 26 regex_internal.h regex.c \
15 regex_graph.c regex_random.c 27 regex_graph.c regex_random.c \
28 regex_dht.c
16libgnunetregex_la_LIBADD = -lm \ 29libgnunetregex_la_LIBADD = -lm \
17 $(top_builddir)/src/util/libgnunetutil.la 30 $(top_builddir)/src/util/libgnunetutil.la \
31 $(top_builddir)/src/dht/libgnunetdht.la \
32 $(top_builddir)/src/statistics/libgnunetstatistics.la \
33 $(top_builddir)/src/regex/libgnunetregexblock.la
18libgnunetregex_la_LDFLAGS = \ 34libgnunetregex_la_LDFLAGS = \
19 $(GN_LIB_LDFLAGS) \ 35 $(GN_LIB_LDFLAGS) \
20 -version-info 1:1:0 36 -version-info 1:1:0
21 37
38
39plugindir = $(libdir)/gnunet
40
41plugin_LTLIBRARIES = \
42 libgnunet_plugin_block_regex.la
43
44libgnunet_plugin_block_regex_la_SOURCES = \
45 plugin_block_regex.c
46libgnunet_plugin_block_regex_la_LIBADD = \
47 $(top_builddir)/src/regex/libgnunetregexblock.la \
48 $(top_builddir)/src/block/libgnunetblock.la \
49 $(top_builddir)/src/util/libgnunetutil.la
50libgnunet_plugin_block_regex_la_LDFLAGS = \
51 $(GN_PLUGIN_LDFLAGS)
52libgnunet_plugin_block_regex_la_DEPENDENCIES = \
53 $(top_builddir)/src/regex/libgnunetregexblock.la \
54 $(top_builddir)/src/block/libgnunetblock.la \
55 $(top_builddir)/src/util/libgnunetutil.la
56
57
22if HAVE_MYSQL 58if HAVE_MYSQL
23noinst_mysql_progs = \ 59noinst_mysql_progs = \
24gnunet-regex-simulation-profiler 60gnunet-regex-simulation-profiler