aboutsummaryrefslogtreecommitdiff
path: root/src/rest/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2015-09-14 11:10:11 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2015-09-14 11:10:11 +0000
commitb0a03eeebfdedbb7b0070ef00514f321aafa49db (patch)
tree06233b8dc0c1bf8ee580367e772c9951a3d7cee6 /src/rest/Makefile.am
parent134da182130592c78bdb5d348826825665a2ffab (diff)
downloadgnunet-b0a03eeebfdedbb7b0070ef00514f321aafa49db.tar.gz
gnunet-b0a03eeebfdedbb7b0070ef00514f321aafa49db.zip
- revert plugin move. Add new identity-token
Diffstat (limited to 'src/rest/Makefile.am')
-rw-r--r--src/rest/Makefile.am37
1 files changed, 1 insertions, 36 deletions
diff --git a/src/rest/Makefile.am b/src/rest/Makefile.am
index cd429abc1..9ab7c03e0 100644
--- a/src/rest/Makefile.am
+++ b/src/rest/Makefile.am
@@ -20,13 +20,8 @@ if USE_COVERAGE
20 XLIBS = -lgcov 20 XLIBS = -lgcov
21endif 21endif
22 22
23REST_PLUGINS = libgnunet_plugin_rest_gns.la \
24 libgnunet_plugin_rest_identity.la \
25 libgnunet_plugin_rest_namestore.la
26
27lib_LTLIBRARIES = \ 23lib_LTLIBRARIES = \
28 libgnunetrest.la \ 24 libgnunetrest.la
29 $(REST_PLUGINS)
30 25
31libexec_PROGRAMS = \ 26libexec_PROGRAMS = \
32 gnunet-rest-server 27 gnunet-rest-server
@@ -48,33 +43,3 @@ libgnunetrest_la_LDFLAGS = \
48 $(GN_LIB_LDFLAGS) \ 43 $(GN_LIB_LDFLAGS) \
49 -version-info 0:0:0 44 -version-info 0:0:0
50 45
51libgnunet_plugin_rest_gns_la_SOURCES = \
52 plugin_rest_gns.c
53libgnunet_plugin_rest_gns_la_LIBADD = \
54 $(top_builddir)/src/gns/libgnunetgns.la \
55 $(top_builddir)/src/identity/libgnunetidentity.la \
56 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
57 $(LTLIBINTL) -ljansson -lmicrohttpd
58libgnunet_plugin_rest_gns_la_LDFLAGS = \
59 $(GN_PLUGIN_LDFLAGS)
60
61
62libgnunet_plugin_rest_identity_la_SOURCES = \
63 plugin_rest_namestore.c
64libgnunet_plugin_rest_identity_la_LIBADD = \
65 $(top_builddir)/src/identity/libgnunetidentity.la \
66 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
67 $(LTLIBINTL) -ljansson -lmicrohttpd
68libgnunet_plugin_rest_identity_la_LDFLAGS = \
69 $(GN_PLUGIN_LDFLAGS)
70
71libgnunet_plugin_rest_namestore_la_SOURCES = \
72 plugin_rest_namestore.c
73libgnunet_plugin_rest_namestore_la_LIBADD = \
74 $(top_builddir)/src/namestore/libgnunetnamestore.la \
75 $(top_builddir)/src/identity/libgnunetidentity.la \
76 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
77 $(LTLIBINTL) -ljansson -lmicrohttpd
78libgnunet_plugin_rest_namestore_la_LDFLAGS = \
79 $(GN_PLUGIN_LDFLAGS)
80