aboutsummaryrefslogtreecommitdiff
path: root/src/rest/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2015-09-11 15:56:39 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2015-09-11 15:56:39 +0000
commitc8aace43c41d50e03bd28b6e696b33c1da8b6c4c (patch)
tree375181e89bd4f099e0a2039ed0962bf7cfd48131 /src/rest/Makefile.am
parenta12f20bd4c621a7b5e88ca52830ad1bb74a8e2d8 (diff)
downloadgnunet-c8aace43c41d50e03bd28b6e696b33c1da8b6c4c.tar.gz
gnunet-c8aace43c41d50e03bd28b6e696b33c1da8b6c4c.zip
- move rest plugins into rest directory where they belong
Diffstat (limited to 'src/rest/Makefile.am')
-rw-r--r--src/rest/Makefile.am39
1 files changed, 38 insertions, 1 deletions
diff --git a/src/rest/Makefile.am b/src/rest/Makefile.am
index 8ea87fc6a..cd429abc1 100644
--- a/src/rest/Makefile.am
+++ b/src/rest/Makefile.am
@@ -20,12 +20,18 @@ if USE_COVERAGE
20 XLIBS = -lgcov 20 XLIBS = -lgcov
21endif 21endif
22 22
23REST_PLUGINS = libgnunet_plugin_rest_gns.la \
24 libgnunet_plugin_rest_identity.la \
25 libgnunet_plugin_rest_namestore.la
26
23lib_LTLIBRARIES = \ 27lib_LTLIBRARIES = \
24 libgnunetrest.la 28 libgnunetrest.la \
29 $(REST_PLUGINS)
25 30
26libexec_PROGRAMS = \ 31libexec_PROGRAMS = \
27 gnunet-rest-server 32 gnunet-rest-server
28 33
34
29gnunet_rest_server_SOURCES = \ 35gnunet_rest_server_SOURCES = \
30 gnunet-rest-server.c 36 gnunet-rest-server.c
31 37
@@ -41,3 +47,34 @@ libgnunetrest_la_LIBADD = \
41libgnunetrest_la_LDFLAGS = \ 47libgnunetrest_la_LDFLAGS = \
42 $(GN_LIB_LDFLAGS) \ 48 $(GN_LIB_LDFLAGS) \
43 -version-info 0:0:0 49 -version-info 0:0:0
50
51libgnunet_plugin_rest_gns_la_SOURCES = \
52 plugin_rest_gns.c
53libgnunet_plugin_rest_gns_la_LIBADD = \
54 $(top_builddir)/src/gns/libgnunetgns.la \
55 $(top_builddir)/src/identity/libgnunetidentity.la \
56 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
57 $(LTLIBINTL) -ljansson -lmicrohttpd
58libgnunet_plugin_rest_gns_la_LDFLAGS = \
59 $(GN_PLUGIN_LDFLAGS)
60
61
62libgnunet_plugin_rest_identity_la_SOURCES = \
63 plugin_rest_namestore.c
64libgnunet_plugin_rest_identity_la_LIBADD = \
65 $(top_builddir)/src/identity/libgnunetidentity.la \
66 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
67 $(LTLIBINTL) -ljansson -lmicrohttpd
68libgnunet_plugin_rest_identity_la_LDFLAGS = \
69 $(GN_PLUGIN_LDFLAGS)
70
71libgnunet_plugin_rest_namestore_la_SOURCES = \
72 plugin_rest_namestore.c
73libgnunet_plugin_rest_namestore_la_LIBADD = \
74 $(top_builddir)/src/namestore/libgnunetnamestore.la \
75 $(top_builddir)/src/identity/libgnunetidentity.la \
76 $(top_builddir)/src/util/libgnunetutil.la $(XLIBS) \
77 $(LTLIBINTL) -ljansson -lmicrohttpd
78libgnunet_plugin_rest_namestore_la_LDFLAGS = \
79 $(GN_PLUGIN_LDFLAGS)
80