aboutsummaryrefslogtreecommitdiff
path: root/src/rest/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2015-03-25 15:58:38 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2015-03-25 15:58:38 +0000
commit08cd39e74d35cec73f54de9826961a97d8a8ea0d (patch)
treef85511b479dc9480427dffaaaa5425ebc221c87c /src/rest/Makefile.am
parent00f87691363acaf94f533793654e610e46bf4e1d (diff)
downloadgnunet-08cd39e74d35cec73f54de9826961a97d8a8ea0d.tar.gz
gnunet-08cd39e74d35cec73f54de9826961a97d8a8ea0d.zip
-start a lib for REST and json:api
Diffstat (limited to 'src/rest/Makefile.am')
-rw-r--r--src/rest/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/rest/Makefile.am b/src/rest/Makefile.am
index 00021cce2..8ea87fc6a 100644
--- a/src/rest/Makefile.am
+++ b/src/rest/Makefile.am
@@ -20,6 +20,9 @@ if USE_COVERAGE
20 XLIBS = -lgcov 20 XLIBS = -lgcov
21endif 21endif
22 22
23lib_LTLIBRARIES = \
24 libgnunetrest.la
25
23libexec_PROGRAMS = \ 26libexec_PROGRAMS = \
24 gnunet-rest-server 27 gnunet-rest-server
25 28
@@ -29,3 +32,12 @@ gnunet_rest_server_SOURCES = \
29gnunet_rest_server_LDADD = \ 32gnunet_rest_server_LDADD = \
30 $(top_builddir)/src/util/libgnunetutil.la \ 33 $(top_builddir)/src/util/libgnunetutil.la \
31 $(GN_LIBINTL) -lmicrohttpd 34 $(GN_LIBINTL) -lmicrohttpd
35
36libgnunetrest_la_SOURCES = \
37 rest.c
38libgnunetrest_la_LIBADD = \
39 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \
40 $(GN_LIBINTL) -lmicrohttpd -ljansson
41libgnunetrest_la_LDFLAGS = \
42 $(GN_LIB_LDFLAGS) \
43 -version-info 0:0:0