aboutsummaryrefslogtreecommitdiff
path: root/src/rps/Makefile.am
diff options
context:
space:
mode:
authorJulius Bünger <buenger@mytum.de>2015-11-27 13:50:11 +0000
committerJulius Bünger <buenger@mytum.de>2015-11-27 13:50:11 +0000
commit4f1848078a92664adc7de9f302ff2a6831e4496c (patch)
treec92b42d0e302f9e850d04049b2d1465033dfa650 /src/rps/Makefile.am
parent2d8f0236f4af6657b913e0fb3b155d7ca84a4b13 (diff)
downloadgnunet-4f1848078a92664adc7de9f302ff2a6831e4496c.tar.gz
gnunet-4f1848078a92664adc7de9f302ff2a6831e4496c.zip
added a custom list/peer-/hashmap structure for use in rps
Signed-off-by: Julius Bünger <buenger@mytum.de>
Diffstat (limited to 'src/rps/Makefile.am')
-rw-r--r--src/rps/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/rps/Makefile.am b/src/rps/Makefile.am
index 8346f6c77..4091b2c17 100644
--- a/src/rps/Makefile.am
+++ b/src/rps/Makefile.am
@@ -68,6 +68,7 @@ gnunet_service_rps_LDADD = \
68 68
69if HAVE_TESTING 69if HAVE_TESTING
70check_PROGRAMS = \ 70check_PROGRAMS = \
71 test_service_rps_peers \
71 test_rps_malicious_1 \ 72 test_rps_malicious_1 \
72 test_rps_malicious_2 \ 73 test_rps_malicious_2 \
73 test_rps_malicious_3 \ 74 test_rps_malicious_3 \
@@ -93,6 +94,10 @@ AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PAT
93TESTS = $(check_PROGRAMS) 94TESTS = $(check_PROGRAMS)
94endif 95endif
95 96
97test_service_rps_peers_SOURCES = gnunet-service-rps_peers.h gnunet-service-rps_peers.c \
98 test_service_rps_peers.c
99test_service_rps_peers_LDADD = $(top_builddir)/src/util/libgnunetutil.la
100
96test_rps_malicious_1_SOURCES = $(rps_test_src) 101test_rps_malicious_1_SOURCES = $(rps_test_src)
97test_rps_malicious_1_LDADD = $(ld_rps_test_lib) 102test_rps_malicious_1_LDADD = $(ld_rps_test_lib)
98 103