aboutsummaryrefslogtreecommitdiff
path: root/src/rps/Makefile.am
diff options
context:
space:
mode:
authorJulius Bünger <buenger@mytum.de>2015-04-07 13:13:48 +0000
committerJulius Bünger <buenger@mytum.de>2015-04-07 13:13:48 +0000
commitdf42828651e3f814a9b4a51dde916db10144cf23 (patch)
treeda348130e4c6d777d7435dd7d1d6b35e2e1e8a69 /src/rps/Makefile.am
parentd780cfa0eca9d603d59f7fb0380088fe096a7e57 (diff)
downloadgnunet-df42828651e3f814a9b4a51dde916db10144cf23.tar.gz
gnunet-df42828651e3f814a9b4a51dde916db10144cf23.zip
compile test to profiler
Diffstat (limited to 'src/rps/Makefile.am')
-rw-r--r--src/rps/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/rps/Makefile.am b/src/rps/Makefile.am
index 76f935723..844677ab9 100644
--- a/src/rps/Makefile.am
+++ b/src/rps/Makefile.am
@@ -40,6 +40,11 @@ libgnunetrps_la_LDFLAGS = \
40libexec_PROGRAMS = \ 40libexec_PROGRAMS = \
41 gnunet-service-rps 41 gnunet-service-rps
42 42
43if HAVE_TESTING
44check_PROGRAMS = \
45 gnunet-nse-profiler
46endif
47
43 48
44gnunet_service_rps_SOURCES = \ 49gnunet_service_rps_SOURCES = \
45 gnunet-service-rps_sampler.h gnunet-service-rps_sampler.c \ 50 gnunet-service-rps_sampler.h gnunet-service-rps_sampler.c \
@@ -56,10 +61,12 @@ gnunet_service_rps_LDADD = \
56 -lm -lgcrypt \ 61 -lm -lgcrypt \
57 $(GN_LIBINTL) 62 $(GN_LIBINTL)
58 63
64
59if HAVE_TESTING 65if HAVE_TESTING
60check_PROGRAMS = \ 66check_PROGRAMS = \
61 test_rps_malicious_1 \ 67 test_rps_malicious_1 \
62 test_rps_malicious_2 \ 68 test_rps_malicious_2 \
69 test_rps_malicious_3 \
63 test_rps_seed_request \ 70 test_rps_seed_request \
64 test_rps_single_req 71 test_rps_single_req
65endif 72endif
@@ -84,6 +91,10 @@ test_rps_malicious_2_SOURCES = \
84 test_rps.c 91 test_rps.c
85test_rps_malicious_2_LDADD = $(ld_rps_test_lib) 92test_rps_malicious_2_LDADD = $(ld_rps_test_lib)
86 93
94test_rps_malicious_3_SOURCES = \
95 test_rps.c
96test_rps_malicious_3_LDADD = $(ld_rps_test_lib)
97
87test_rps_single_req_SOURCES = \ 98test_rps_single_req_SOURCES = \
88 test_rps.c 99 test_rps.c
89test_rps_single_req_LDADD = $(ld_rps_test_lib) 100test_rps_single_req_LDADD = $(ld_rps_test_lib)
@@ -92,6 +103,10 @@ test_rps_seed_request_SOURCES = \
92 test_rps.c 103 test_rps.c
93test_rps_seed_request_LDADD = $(ld_rps_test_lib) 104test_rps_seed_request_LDADD = $(ld_rps_test_lib)
94 105
106gnunet_nse_profiler_SOURCES = \
107 test_rps.c
108gnunet_nse_profiler_LDADD = $(ld_rps_test_lib)
109
95EXTRA_DIST = \ 110EXTRA_DIST = \
96 test_rps.conf 111 test_rps.conf
97 112