aboutsummaryrefslogtreecommitdiff
path: root/src/social/Makefile.am
diff options
context:
space:
mode:
authorGabor X Toth <*@tg-x.net>2014-07-23 16:19:49 +0000
committerGabor X Toth <*@tg-x.net>2014-07-23 16:19:49 +0000
commit3cf8ba0b60f8495892fa76635e9c23555d0a304c (patch)
tree5f27648bdb3cf3409628e4e5edc26f811cbd03a5 /src/social/Makefile.am
parent252b5599987b7ba03b879a8c2d1c455ad4c9834a (diff)
downloadgnunet-3cf8ba0b60f8495892fa76635e9c23555d0a304c.tar.gz
gnunet-3cf8ba0b60f8495892fa76635e9c23555d0a304c.zip
social: implement enter/leave/messaging; psyc: improvements and fixes
- social: implement enter/leave, send/receive messages, slicer - psyc, social: add struct GNUNET_PSYC_Message for single-fragment join messages - psyc: add message callback in addition to message part callback - client_manager, social, psyc, multicast: add disconnect callback
Diffstat (limited to 'src/social/Makefile.am')
-rw-r--r--src/social/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/social/Makefile.am b/src/social/Makefile.am
index 04184dbc6..02b1bf823 100644
--- a/src/social/Makefile.am
+++ b/src/social/Makefile.am
@@ -24,6 +24,11 @@ libgnunetsocial_la_SOURCES = \
24libgnunetsocial_la_LIBADD = \ 24libgnunetsocial_la_LIBADD = \
25 $(top_builddir)/src/util/libgnunetutil.la \ 25 $(top_builddir)/src/util/libgnunetutil.la \
26 $(top_builddir)/src/env/libgnunetenv.la \ 26 $(top_builddir)/src/env/libgnunetenv.la \
27 $(top_builddir)/src/psyc/libgnunetpsycutil.la \
28 $(top_builddir)/src/core/libgnunetcore.la \
29 $(top_builddir)/src/identity/libgnunetidentity.la \
30 $(top_builddir)/src/gns/libgnunetgns.la \
31 $(top_builddir)/src/namestore/libgnunetnamestore.la \
27 $(GN_LIBINTL) $(XLIB) 32 $(GN_LIBINTL) $(XLIB)
28libgnunetsocial_la_LDFLAGS = \ 33libgnunetsocial_la_LDFLAGS = \
29 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 34 $(GN_LIB_LDFLAGS) $(WINFLAGS) \