aboutsummaryrefslogtreecommitdiff
path: root/src/statistics/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-07-09 11:19:47 +0000
committerChristian Grothoff <christian@grothoff.org>2012-07-09 11:19:47 +0000
commit8bdc9a4b52d7b36c2beacdf645a64d4f200ec280 (patch)
tree155e887260cfe79fdae0bec16fe054d75802f8f8 /src/statistics/Makefile.am
parent078713080ee376ba8a490c70c474a1a2d22189c8 (diff)
downloadgnunet-8bdc9a4b52d7b36c2beacdf645a64d4f200ec280.tar.gz
gnunet-8bdc9a4b52d7b36c2beacdf645a64d4f200ec280.zip
-LRN: Python-based test script for statistics
Diffstat (limited to 'src/statistics/Makefile.am')
-rw-r--r--src/statistics/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/statistics/Makefile.am b/src/statistics/Makefile.am
index ddf5fda0e..5485a9c18 100644
--- a/src/statistics/Makefile.am
+++ b/src/statistics/Makefile.am
@@ -83,10 +83,20 @@ test_statistics_api_watch_zero_value_LDADD = \
83 $(top_builddir)/src/util/libgnunetutil.la 83 $(top_builddir)/src/util/libgnunetutil.la
84 84
85check_SCRIPTS = \ 85check_SCRIPTS = \
86 test_gnunet_statistics.sh 86 test_gnunet_statistics.py
87
88do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
89
90%.py: %.py.in Makefile
91 $(do_subst) < $(srcdir)/$< > $@
92 chmod +x $@
93
94test_gnunet_statistics.py: test_gnunet_statistics.py.in Makefile
95 $(do_subst) < $(srcdir)/test_gnunet_statistics.py.in > test_gnunet_statistics.py
96 chmod +x test_gnunet_statistics.py
87 97
88EXTRA_DIST = \ 98EXTRA_DIST = \
89 test_statistics_api_data.conf \ 99 test_statistics_api_data.conf \
90 $(check_SCRIPTS) 100 test_gnunet_statistics.py.in
91 101
92 102