aboutsummaryrefslogtreecommitdiff
path: root/src/testbed/Makefile.am
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2013-09-03 13:56:59 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2013-09-03 13:56:59 +0000
commit4131b927fffb82e9196f39c774506a63b538324f (patch)
treeaf3f6242662cdc765dab7f5403ac584fdd5b7450 /src/testbed/Makefile.am
parentd03b4469e0d1ccc0d670ebee14a354511fa56bda (diff)
downloadgnunet-4131b927fffb82e9196f39c774506a63b538324f.tar.gz
gnunet-4131b927fffb82e9196f39c774506a63b538324f.zip
- build system changes for testing barriers API
Diffstat (limited to 'src/testbed/Makefile.am')
-rw-r--r--src/testbed/Makefile.am36
1 files changed, 33 insertions, 3 deletions
diff --git a/src/testbed/Makefile.am b/src/testbed/Makefile.am
index f07639b8a..4c204c4a8 100644
--- a/src/testbed/Makefile.am
+++ b/src/testbed/Makefile.am
@@ -30,6 +30,15 @@ bin_PROGRAMS = \
30 $(ll_binaries) \ 30 $(ll_binaries) \
31 gnunet-testbed-profiler 31 gnunet-testbed-profiler
32 32
33noinst_SCRIPTS = \
34 buildvars.py
35
36CLEANFILES = $(noinst_SCRIPTS) \
37 buildvars.pyc
38
39noinst_PROGRAMS = \
40 gnunet-service-test-barriers
41
33gnunet_service_testbed_SOURCES = \ 42gnunet_service_testbed_SOURCES = \
34 gnunet-service-testbed.h \ 43 gnunet-service-testbed.h \
35 gnunet-service-testbed.c \ 44 gnunet-service-testbed.c \
@@ -150,7 +159,8 @@ check_PROGRAMS = \
150 test_testbed_api_testbed_run_topologyfromfile \ 159 test_testbed_api_testbed_run_topologyfromfile \
151 test_testbed_api_testbed_run_topologyscalefree \ 160 test_testbed_api_testbed_run_topologyscalefree \
152 test_testbed_api_testbed_run_waitforever \ 161 test_testbed_api_testbed_run_waitforever \
153 test_testbed_api_statistics 162 test_testbed_api_statistics \
163 test_testbed_api_barriers
154 164
155if ENABLE_TEST_RUN 165if ENABLE_TEST_RUN
156 TESTS = \ 166 TESTS = \
@@ -179,7 +189,8 @@ if ENABLE_TEST_RUN
179 test_testbed_api_testbed_run_topologysmallworld \ 189 test_testbed_api_testbed_run_topologysmallworld \
180 test_testbed_api_testbed_run_topologysmallworldring \ 190 test_testbed_api_testbed_run_topologysmallworldring \
181 test_testbed_api_testbed_run_topologyfromfile \ 191 test_testbed_api_testbed_run_topologyfromfile \
182 test_testbed_api_testbed_run_topologyscalefree 192 test_testbed_api_testbed_run_topologyscalefree \
193 test_testbed_api_barriers.py
183endif 194endif
184 195
185test_testbed_api_hosts_SOURCES = \ 196test_testbed_api_hosts_SOURCES = \
@@ -350,6 +361,23 @@ test_testbed_api_peer_reconfiguration_LDADD = \
350 $(top_builddir)/src/util/libgnunetutil.la \ 361 $(top_builddir)/src/util/libgnunetutil.la \
351 libgnunettestbed.la 362 libgnunettestbed.la
352 363
364test_testbed_api_barriers_SOURCES = \
365 test_testbed_api_barriers.c
366test_testbed_api_barriers_LDADD = \
367 $(top_builddir)/src/util/libgnunetutil.la \
368 libgnunettestbed.la
369
370do_subst = sed -e 's,[@]libexecdir[@],$(libexecdir),g'
371
372buildvars.py: buildvars.py.in Makefile
373 $(do_subst) < $(srcdir)/buildvars.py.in > $@
374
375gnunet_service_test_barriers_SOURCES = \
376 gnunet-service-test-barriers.c
377gnunet_service_test_barriers_LDADD = \
378 $(top_builddir)/src/util/libgnunetutil.la \
379 libgnunettestbed.la
380
353EXTRA_DIST = \ 381EXTRA_DIST = \
354 test_testbed_api.conf \ 382 test_testbed_api.conf \
355 test_testbed_api_test_timeout.conf \ 383 test_testbed_api_test_timeout.conf \
@@ -364,4 +392,6 @@ EXTRA_DIST = \
364 test_testbed_api_testbed_run_topologyscalefree.conf \ 392 test_testbed_api_testbed_run_topologyscalefree.conf \
365 overlay_topology.txt \ 393 overlay_topology.txt \
366 sample_hosts.txt \ 394 sample_hosts.txt \
367 sample.job 395 sample.job \
396 buildvars.py.in \
397 test_testbed_api_barriers.py