aboutsummaryrefslogtreecommitdiff
path: root/src/testbed/Makefile.am
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2013-04-26 08:47:58 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2013-04-26 08:47:58 +0000
commita5e2b65182c5e73f723f2b49d07aabfbe54ad112 (patch)
treec04c725718c5940908990b275f0d6c2d54de75b3 /src/testbed/Makefile.am
parent45b8f1cfb99e0f75139fb935763556c8dc39807b (diff)
downloadgnunet-a5e2b65182c5e73f723f2b49d07aabfbe54ad112.tar.gz
gnunet-a5e2b65182c5e73f723f2b49d07aabfbe54ad112.zip
- signal termination to peers when controller crashes
Diffstat (limited to 'src/testbed/Makefile.am')
-rw-r--r--src/testbed/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/testbed/Makefile.am b/src/testbed/Makefile.am
index 3802cfebe..e95dd3fa1 100644
--- a/src/testbed/Makefile.am
+++ b/src/testbed/Makefile.am
@@ -144,6 +144,7 @@ check_PROGRAMS = \
144 test_testbed_api_testbed_run_topologysmallworld \ 144 test_testbed_api_testbed_run_topologysmallworld \
145 test_testbed_api_testbed_run_topologyfromfile \ 145 test_testbed_api_testbed_run_topologyfromfile \
146 test_testbed_api_testbed_run_topologyscalefree \ 146 test_testbed_api_testbed_run_topologyscalefree \
147 test_testbed_api_testbed_run_waitforever \ #Can be used for manual debugging
147 test_testbed_api_statistics 148 test_testbed_api_statistics
148 149
149if ENABLE_TEST_RUN 150if ENABLE_TEST_RUN
@@ -319,6 +320,12 @@ test_testbed_api_testbed_run_topologyscalefree_LDADD = \
319 $(top_builddir)/src/util/libgnunetutil.la \ 320 $(top_builddir)/src/util/libgnunetutil.la \
320 libgnunettestbed.la 321 libgnunettestbed.la
321 322
323test_testbed_api_testbed_run_waitforever_SOURCES = \
324 test_testbed_api_testbed_run.c
325test_testbed_api_testbed_run_waitforever_LDADD = \
326 $(top_builddir)/src/util/libgnunetutil.la \
327 libgnunettestbed.la
328
322test_testbed_api_statistics_SOURCES = \ 329test_testbed_api_statistics_SOURCES = \
323 test_testbed_api_statistics.c 330 test_testbed_api_statistics.c
324test_testbed_api_statistics_LDADD = \ 331test_testbed_api_statistics_LDADD = \