aboutsummaryrefslogtreecommitdiff
path: root/src/testbed/Makefile.am
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2013-04-02 16:54:35 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2013-04-02 16:54:35 +0000
commit8eb1702f2a5944ebdccae9d9e37b58e6fec290cc (patch)
treef67caa35a36afaf61ca7e57f0f816e26f2132712 /src/testbed/Makefile.am
parent68eb732cc6e17c765a00eb6841130b0e3b9de9b3 (diff)
downloadgnunet-8eb1702f2a5944ebdccae9d9e37b58e6fec290cc.tar.gz
gnunet-8eb1702f2a5944ebdccae9d9e37b58e6fec290cc.zip
- test case for starting/stopping peer's services
Diffstat (limited to 'src/testbed/Makefile.am')
-rw-r--r--src/testbed/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/testbed/Makefile.am b/src/testbed/Makefile.am
index 20056fba1..af61135f6 100644
--- a/src/testbed/Makefile.am
+++ b/src/testbed/Makefile.am
@@ -102,6 +102,7 @@ libgnunettestbed_la_LDFLAGS = \
102 102
103check_PROGRAMS = \ 103check_PROGRAMS = \
104 test_testbed_api_hosts \ 104 test_testbed_api_hosts \
105 test_gnunet_helper_testbed \
105 test_testbed_api_controllerlink \ 106 test_testbed_api_controllerlink \
106 test_testbed_api_2peers_1controller \ 107 test_testbed_api_2peers_1controller \
107 test_testbed_api_3peers_3controllers \ 108 test_testbed_api_3peers_3controllers \
@@ -111,7 +112,7 @@ check_PROGRAMS = \
111 test_testbed_api_testbed_run \ 112 test_testbed_api_testbed_run \
112 test_testbed_api_test \ 113 test_testbed_api_test \
113 test_testbed_api_test_timeout \ 114 test_testbed_api_test_timeout \
114 test_gnunet_helper_testbed \ 115 test_testbed_api_peers_manage_services \
115 test_testbed_api_topology \ 116 test_testbed_api_topology \
116 test_testbed_api_topology_clique \ 117 test_testbed_api_topology_clique \
117 test_testbed_api_testbed_run_topologyrandom \ 118 test_testbed_api_testbed_run_topologyrandom \
@@ -139,6 +140,7 @@ if ENABLE_TEST_RUN
139 test_testbed_api_test \ 140 test_testbed_api_test \
140 test_testbed_api_test_timeout \ 141 test_testbed_api_test_timeout \
141 test_testbed_api_statistics \ 142 test_testbed_api_statistics \
143 test_testbed_api_peers_manage_services \
142 test_testbed_api_topology \ 144 test_testbed_api_topology \
143 test_testbed_api_topology_clique \ 145 test_testbed_api_topology_clique \
144 test_testbed_api_testbed_run_topologyrandom \ 146 test_testbed_api_testbed_run_topologyrandom \
@@ -295,6 +297,12 @@ test_testbed_api_statistics_LDADD = \
295 $(top_builddir)/src/util/libgnunetutil.la \ 297 $(top_builddir)/src/util/libgnunetutil.la \
296 libgnunettestbed.la 298 libgnunettestbed.la
297 299
300test_testbed_api_peers_manage_services_SOURCES = \
301 test_testbed_api_peers_manage_services.c
302test_testbed_api_peers_manage_services_LDADD = \
303 $(top_builddir)/src/util/libgnunetutil.la \
304 libgnunettestbed.la
305
298EXTRA_DIST = \ 306EXTRA_DIST = \
299 test_testbed_api.conf \ 307 test_testbed_api.conf \
300 test_testbed_api_test_timeout.conf \ 308 test_testbed_api_test_timeout.conf \