aboutsummaryrefslogtreecommitdiff
path: root/src/testbed/Makefile.am
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2013-03-13 10:51:45 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2013-03-13 10:51:45 +0000
commit0043aada3f5172d461f89eecc9138b6a1754ca14 (patch)
tree6970bdc8d0acf430db3b6dee674149a2aeb9273a /src/testbed/Makefile.am
parente27e2a35da519f85d7597890557f83a4d432e414 (diff)
downloadgnunet-0043aada3f5172d461f89eecc9138b6a1754ca14.tar.gz
gnunet-0043aada3f5172d461f89eecc9138b6a1754ca14.zip
Implement GNUNET_TESTBED_get_statistics() - resolves #2662
Test case for testing GNUNET_TESTBED_get_statistics() Fix waiting for SHUTDOWN_PEERS reply when controller crashes
Diffstat (limited to 'src/testbed/Makefile.am')
-rw-r--r--src/testbed/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/testbed/Makefile.am b/src/testbed/Makefile.am
index 2189de3cb..bc703ebcb 100644
--- a/src/testbed/Makefile.am
+++ b/src/testbed/Makefile.am
@@ -120,7 +120,8 @@ check_PROGRAMS = \
120 test_testbed_api_testbed_run_topology2dtorus \ 120 test_testbed_api_testbed_run_topology2dtorus \
121 test_testbed_api_testbed_run_topologysmallworld \ 121 test_testbed_api_testbed_run_topologysmallworld \
122 test_testbed_api_testbed_run_topologyfromfile \ 122 test_testbed_api_testbed_run_topologyfromfile \
123 test_testbed_api_testbed_run_topologyscalefree 123 test_testbed_api_testbed_run_topologyscalefree \
124 test_testbed_api_statistics
124 125
125if ENABLE_TEST_RUN 126if ENABLE_TEST_RUN
126 TESTS = \ 127 TESTS = \
@@ -134,6 +135,7 @@ if ENABLE_TEST_RUN
134 test_testbed_api_3peers_3controllers \ 135 test_testbed_api_3peers_3controllers \
135 test_testbed_api_testbed_run \ 136 test_testbed_api_testbed_run \
136 test_testbed_api_test \ 137 test_testbed_api_test \
138 test_testbed_api_statistics \
137 test_testbed_api_topology \ 139 test_testbed_api_topology \
138 test_testbed_api_topology_clique \ 140 test_testbed_api_topology_clique \
139 test_testbed_api_testbed_run_topologyrandom \ 141 test_testbed_api_testbed_run_topologyrandom \
@@ -278,6 +280,12 @@ test_testbed_api_testbed_run_topologyscalefree_LDADD = \
278 $(top_builddir)/src/util/libgnunetutil.la \ 280 $(top_builddir)/src/util/libgnunetutil.la \
279 libgnunettestbed.la 281 libgnunettestbed.la
280 282
283test_testbed_api_statistics_SOURCES = \
284 test_testbed_api_statistics.c
285test_testbed_api_statistics_LDADD = \
286 $(top_builddir)/src/util/libgnunetutil.la \
287 libgnunettestbed.la
288
281EXTRA_DIST = \ 289EXTRA_DIST = \
282 test_testbed_api.conf \ 290 test_testbed_api.conf \
283 test_testbed_api_testbed_run_topologyring.conf \ 291 test_testbed_api_testbed_run_topologyring.conf \