aboutsummaryrefslogtreecommitdiff
path: root/src/testbed/Makefile.am
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2012-12-07 15:46:25 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2012-12-07 15:46:25 +0000
commit0d45e157a134a01ec59e8fc564918a1caa5070c4 (patch)
treeb3ca74f32caed644d7bb212c1f73c463602ccc3c /src/testbed/Makefile.am
parent48b428a4e66e8cf40afac812e4abb97831360501 (diff)
downloadgnunet-0d45e157a134a01ec59e8fc564918a1caa5070c4.tar.gz
gnunet-0d45e157a134a01ec59e8fc564918a1caa5070c4.zip
- MPI test program
Diffstat (limited to 'src/testbed/Makefile.am')
-rw-r--r--src/testbed/Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/src/testbed/Makefile.am b/src/testbed/Makefile.am
index d8cc9a207..f267a464f 100644
--- a/src/testbed/Makefile.am
+++ b/src/testbed/Makefile.am
@@ -10,9 +10,12 @@ if USE_COVERAGE
10endif 10endif
11 11
12if WITH_LL 12if WITH_LL
13 ll_binaries = \ 13 CC = mpcc
14 ll_noinst_binaries = \
14 ll-master \ 15 ll-master \
15 ll-monitor 16 ll-monitor
17 ll_binaries = \
18 gnunet-mpi-test
16endif 19endif
17 20
18libexecdir= $(pkglibdir)/libexec/ 21libexecdir= $(pkglibdir)/libexec/
@@ -26,9 +29,12 @@ libexec_PROGRAMS = \
26 gnunet-service-testbed \ 29 gnunet-service-testbed \
27 gnunet-helper-testbed 30 gnunet-helper-testbed
28 31
32bin_PROGRAMS = \
33 $(ll_binaries)
34
29noinst_PROGRAMS = \ 35noinst_PROGRAMS = \
30 gnunet-testbed-profiler \ 36 gnunet-testbed-profiler \
31 $(ll_binaries) 37 $(ll_noinst_binaries)
32 38
33gnunet_service_testbed_SOURCES = \ 39gnunet_service_testbed_SOURCES = \
34 gnunet-service-testbed.c 40 gnunet-service-testbed.c
@@ -71,6 +77,10 @@ ll_monitor_SOURCES = \
71ll_monitor_LDADD = $(XLIB) \ 77ll_monitor_LDADD = $(XLIB) \
72 $(LTLIBINTL) -lz -lllapi 78 $(LTLIBINTL) -lz -lllapi
73 79
80gnunet_mpi_test_SOURCES = gnunet_mpi_test.c
81gnunet_mpi_test_LDADD = \
82 $(top_builddir)/src/util/libgnunetutil.la
83
74lib_LTLIBRARIES = \ 84lib_LTLIBRARIES = \
75 libgnunettestbed.la 85 libgnunettestbed.la
76 86