aboutsummaryrefslogtreecommitdiff
path: root/src/testbed/Makefile.am
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2012-11-16 17:53:26 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2012-11-16 17:53:26 +0000
commit26bf6d22e5395a03ec3f6ac6164df1f3482da374 (patch)
treebecde8a860504da20f45045815fc9252cce7d252 /src/testbed/Makefile.am
parent5c6866ff424ec0292ea1b5cc637c5a0d87021c82 (diff)
downloadgnunet-26bf6d22e5395a03ec3f6ac6164df1f3482da374.tar.gz
gnunet-26bf6d22e5395a03ec3f6ac6164df1f3482da374.zip
small world topology
Diffstat (limited to 'src/testbed/Makefile.am')
-rw-r--r--src/testbed/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/src/testbed/Makefile.am b/src/testbed/Makefile.am
index 130014836..7230888dc 100644
--- a/src/testbed/Makefile.am
+++ b/src/testbed/Makefile.am
@@ -96,7 +96,8 @@ check_PROGRAMS = \
96 test_testbed_api_testbed_run_topologyclique \ 96 test_testbed_api_testbed_run_topologyclique \
97 test_testbed_api_testbed_run_topologyring \ 97 test_testbed_api_testbed_run_topologyring \
98 test_testbed_api_testbed_run_topologysmallworldring \ 98 test_testbed_api_testbed_run_topologysmallworldring \
99 test_testbed_api_testbed_run_topology2dtorus 99 test_testbed_api_testbed_run_topology2dtorus \
100 test_testbed_api_testbed_run_topologysmallworld
100 101
101if ENABLE_TEST_RUN 102if ENABLE_TEST_RUN
102 TESTS = \ 103 TESTS = \
@@ -116,7 +117,8 @@ if ENABLE_TEST_RUN
116 test_testbed_api_testbed_run_topologyclique \ 117 test_testbed_api_testbed_run_topologyclique \
117 test_testbed_api_testbed_run_topologyring \ 118 test_testbed_api_testbed_run_topologyring \
118 test_testbed_api_testbed_run_topologysmallworldring \ 119 test_testbed_api_testbed_run_topologysmallworldring \
119 test_testbed_api_testbed_run_topology2dtorus 120 test_testbed_api_testbed_run_topology2dtorus \
121 test_testbed_api_testbed_run_topologysmallworld
120endif 122endif
121 123
122test_testbed_api_hosts_SOURCES = \ 124test_testbed_api_hosts_SOURCES = \
@@ -226,6 +228,12 @@ test_testbed_api_testbed_run_topology2dtorus_LDADD = \
226 $(top_builddir)/src/util/libgnunetutil.la \ 228 $(top_builddir)/src/util/libgnunetutil.la \
227 libgnunettestbed.la 229 libgnunettestbed.la
228 230
231test_testbed_api_testbed_run_topologysmallworld_SOURCES = \
232 test_testbed_api_testbed_run.c
233test_testbed_api_testbed_run_topologysmallworld_LDADD = \
234 $(top_builddir)/src/util/libgnunetutil.la \
235 libgnunettestbed.la
236
229EXTRA_DIST = \ 237EXTRA_DIST = \
230 test_testbed_api.conf \ 238 test_testbed_api.conf \
231 test_testbed_api_testbed_run_topologyring.conf \ 239 test_testbed_api_testbed_run_topologyring.conf \
@@ -234,4 +242,5 @@ EXTRA_DIST = \
234 test_testbed_api_testbed_run_topologyrandom.conf \ 242 test_testbed_api_testbed_run_topologyrandom.conf \
235 test_testbed_api_testbed_run_topologysmallworldring.conf \ 243 test_testbed_api_testbed_run_topologysmallworldring.conf \
236 test_testbed_api_testbed_run_topology2dtorus.conf \ 244 test_testbed_api_testbed_run_topology2dtorus.conf \
245 test_testbed_api_testbed_run_topologysmallworld.conf \
237 sample_hosts.txt \ No newline at end of file 246 sample_hosts.txt \ No newline at end of file