aboutsummaryrefslogtreecommitdiff
path: root/src/testbed/Makefile.am
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2012-11-23 12:23:16 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2012-11-23 12:23:16 +0000
commit510ba17ceb93d9f39290154c69e6206985366c7b (patch)
tree3ebf594f834b2332dd074e75389e99f783fa7b3b /src/testbed/Makefile.am
parent4ef4905497e8b34e907649cbe93568ea5f46c83d (diff)
downloadgnunet-510ba17ceb93d9f39290154c69e6206985366c7b.tar.gz
gnunet-510ba17ceb93d9f39290154c69e6206985366c7b.zip
test case for scale free routing
Diffstat (limited to 'src/testbed/Makefile.am')
-rw-r--r--src/testbed/Makefile.am63
1 files changed, 36 insertions, 27 deletions
diff --git a/src/testbed/Makefile.am b/src/testbed/Makefile.am
index 93ea4cf45..1fdbc616f 100644
--- a/src/testbed/Makefile.am
+++ b/src/testbed/Makefile.am
@@ -80,25 +80,26 @@ libgnunettestbed_la_LDFLAGS = \
80 -version-info 0:0:0 80 -version-info 0:0:0
81 81
82check_PROGRAMS = \ 82check_PROGRAMS = \
83 test_testbed_api_hosts \ 83 test_testbed_api_hosts \
84 test_testbed_api_controllerlink \ 84 test_testbed_api_controllerlink \
85 test_testbed_api_2peers_1controller \ 85 test_testbed_api_2peers_1controller \
86 test_testbed_api_3peers_3controllers \ 86 test_testbed_api_3peers_3controllers \
87 test_testbed_api \ 87 test_testbed_api \
88 test_testbed_api_operations \ 88 test_testbed_api_operations \
89 test_testbed_api_testbed_run \ 89 test_testbed_api_testbed_run \
90 test_testbed_api_test \ 90 test_testbed_api_test \
91 test_gnunet_helper_testbed \ 91 test_gnunet_helper_testbed \
92 test_testbed_api_topology \ 92 test_testbed_api_topology \
93 test_testbed_api_topology_clique \ 93 test_testbed_api_topology_clique \
94 test_testbed_api_testbed_run_topologyrandom \ 94 test_testbed_api_testbed_run_topologyrandom \
95 test_testbed_api_testbed_run_topologyline \ 95 test_testbed_api_testbed_run_topologyline \
96 test_testbed_api_testbed_run_topologyclique \ 96 test_testbed_api_testbed_run_topologyclique \
97 test_testbed_api_testbed_run_topologyring \ 97 test_testbed_api_testbed_run_topologyring \
98 test_testbed_api_testbed_run_topologysmallworldring \ 98 test_testbed_api_testbed_run_topologysmallworldring \
99 test_testbed_api_testbed_run_topology2dtorus \ 99 test_testbed_api_testbed_run_topology2dtorus \
100 test_testbed_api_testbed_run_topologysmallworld \ 100 test_testbed_api_testbed_run_topologysmallworld \
101 test_testbed_api_testbed_run_topologyfromfile 101 test_testbed_api_testbed_run_topologyfromfile \
102 test_testbed_api_testbed_run_topologyscalefree
102 103
103if ENABLE_TEST_RUN 104if ENABLE_TEST_RUN
104 TESTS = \ 105 TESTS = \
@@ -113,14 +114,15 @@ if ENABLE_TEST_RUN
113 test_testbed_api_test \ 114 test_testbed_api_test \
114 test_testbed_api_topology \ 115 test_testbed_api_topology \
115 test_testbed_api_topology_clique \ 116 test_testbed_api_topology_clique \
116 test_testbed_api_testbed_run_topologyrandom \ 117 test_testbed_api_testbed_run_topologyrandom \
117 test_testbed_api_testbed_run_topologyline \ 118 test_testbed_api_testbed_run_topologyline \
118 test_testbed_api_testbed_run_topologyclique \ 119 test_testbed_api_testbed_run_topologyclique \
119 test_testbed_api_testbed_run_topologyring \ 120 test_testbed_api_testbed_run_topologyring \
120 test_testbed_api_testbed_run_topologysmallworldring \ 121 test_testbed_api_testbed_run_topologysmallworldring \
121 test_testbed_api_testbed_run_topology2dtorus \ 122 test_testbed_api_testbed_run_topology2dtorus \
122 test_testbed_api_testbed_run_topologysmallworld \ 123 test_testbed_api_testbed_run_topologysmallworld \
123 test_testbed_api_testbed_run_topologyfromfile 124 test_testbed_api_testbed_run_topologyfromfile \
125 test_testbed_api_testbed_run_topologyscalefree
124endif 126endif
125 127
126test_testbed_api_hosts_SOURCES = \ 128test_testbed_api_hosts_SOURCES = \
@@ -242,6 +244,12 @@ test_testbed_api_testbed_run_topologyfromfile_LDADD = \
242 $(top_builddir)/src/util/libgnunetutil.la \ 244 $(top_builddir)/src/util/libgnunetutil.la \
243 libgnunettestbed.la 245 libgnunettestbed.la
244 246
247test_testbed_api_testbed_run_topologyscalefree_SOURCES = \
248 test_testbed_api_testbed_run.c
249test_testbed_api_testbed_run_topologyscalefree_LDADD = \
250 $(top_builddir)/src/util/libgnunetutil.la \
251 libgnunettestbed.la
252
245EXTRA_DIST = \ 253EXTRA_DIST = \
246 test_testbed_api.conf \ 254 test_testbed_api.conf \
247 test_testbed_api_testbed_run_topologyring.conf \ 255 test_testbed_api_testbed_run_topologyring.conf \
@@ -252,5 +260,6 @@ EXTRA_DIST = \
252 test_testbed_api_testbed_run_topology2dtorus.conf \ 260 test_testbed_api_testbed_run_topology2dtorus.conf \
253 test_testbed_api_testbed_run_topologysmallworld.conf \ 261 test_testbed_api_testbed_run_topologysmallworld.conf \
254 test_testbed_api_testbed_run_topologyfromfile.conf \ 262 test_testbed_api_testbed_run_topologyfromfile.conf \
263 test_testbed_api_testbed_run_topologyscalefree.conf \
255 overlay_topology.txt \ 264 overlay_topology.txt \
256 sample_hosts.txt \ No newline at end of file 265 sample_hosts.txt \ No newline at end of file