aboutsummaryrefslogtreecommitdiff
path: root/src/testbed/Makefile.am
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2012-11-01 21:12:56 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2012-11-01 21:12:56 +0000
commit55966806a86ad5f28be24407648e0e707e8fef80 (patch)
treeafa04daf3e127d274bff5f06630a4140d6cd7307 /src/testbed/Makefile.am
parent13361222d8b8d47611d67c240ae2329cdc999a7e (diff)
downloadgnunet-55966806a86ad5f28be24407648e0e707e8fef80.tar.gz
gnunet-55966806a86ad5f28be24407648e0e707e8fef80.zip
topology option support for GNUNET_TESTBED_run() via configuration
Diffstat (limited to 'src/testbed/Makefile.am')
-rw-r--r--src/testbed/Makefile.am28
1 files changed, 26 insertions, 2 deletions
diff --git a/src/testbed/Makefile.am b/src/testbed/Makefile.am
index 6e76b0862..38985c82e 100644
--- a/src/testbed/Makefile.am
+++ b/src/testbed/Makefile.am
@@ -90,7 +90,10 @@ check_PROGRAMS = \
90 test_testbed_api_test \ 90 test_testbed_api_test \
91 test_gnunet_helper_testbed \ 91 test_gnunet_helper_testbed \
92 test_testbed_api_topology \ 92 test_testbed_api_topology \
93 test_testbed_api_topology_clique 93 test_testbed_api_topology_clique \
94 test_testbed_api_testbed_run_topologyrandom \
95 test_testbed_api_testbed_run_topologyline \
96 test_testbed_api_testbed_run_topologyclique
94 97
95if ENABLE_TEST_RUN 98if ENABLE_TEST_RUN
96 TESTS = \ 99 TESTS = \
@@ -104,7 +107,10 @@ if ENABLE_TEST_RUN
104 test_testbed_api_testbed_run \ 107 test_testbed_api_testbed_run \
105 test_testbed_api_test \ 108 test_testbed_api_test \
106 test_testbed_api_topology \ 109 test_testbed_api_topology \
107 test_testbed_api_topology_clique 110 test_testbed_api_topology_clique \
111 test_testbed_api_testbed_run_topologyrandom \
112 test_testbed_api_testbed_run_topologyline \
113 test_testbed_api_testbed_run_topologyclique
108endif 114endif
109 115
110test_testbed_api_hosts_SOURCES = \ 116test_testbed_api_hosts_SOURCES = \
@@ -178,6 +184,24 @@ test_gnunet_helper_testbed_LDADD = \
178 libgnunettestbed.la \ 184 libgnunettestbed.la \
179 -lz 185 -lz
180 186
187test_testbed_api_testbed_run_topologyrandom_SOURCES = \
188 test_testbed_api_testbed_run.c
189test_testbed_api_testbed_run_topologyrandom_LDADD = \
190 $(top_builddir)/src/util/libgnunetutil.la \
191 libgnunettestbed.la
192
193test_testbed_api_testbed_run_topologyline_SOURCES = \
194 test_testbed_api_testbed_run.c
195test_testbed_api_testbed_run_topologyline_LDADD = \
196 $(top_builddir)/src/util/libgnunetutil.la \
197 libgnunettestbed.la
198
199test_testbed_api_testbed_run_topologyclique_SOURCES = \
200 test_testbed_api_testbed_run.c
201test_testbed_api_testbed_run_topologyclique_LDADD = \
202 $(top_builddir)/src/util/libgnunetutil.la \
203 libgnunettestbed.la
204
181 205
182EXTRA_DIST = \ 206EXTRA_DIST = \
183 test_testbed_api.conf 207 test_testbed_api.conf