aboutsummaryrefslogtreecommitdiff
path: root/src/testbed/Makefile.am
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2012-11-12 16:55:33 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2012-11-12 16:55:33 +0000
commit61a51d59b76d8c0ab20e06314e7c2581a2b595a1 (patch)
tree6248ad3b514622e80763401eb408062671c2f353 /src/testbed/Makefile.am
parent89b68440fb41d38d2e441223e66117ef5f8d06f7 (diff)
downloadgnunet-61a51d59b76d8c0ab20e06314e7c2581a2b595a1.tar.gz
gnunet-61a51d59b76d8c0ab20e06314e7c2581a2b595a1.zip
test case for ring topology
Diffstat (limited to 'src/testbed/Makefile.am')
-rw-r--r--src/testbed/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/testbed/Makefile.am b/src/testbed/Makefile.am
index fc189052c..9eee7cf4e 100644
--- a/src/testbed/Makefile.am
+++ b/src/testbed/Makefile.am
@@ -93,7 +93,8 @@ check_PROGRAMS = \
93 test_testbed_api_topology_clique \ 93 test_testbed_api_topology_clique \
94 test_testbed_api_testbed_run_topologyrandom \ 94 test_testbed_api_testbed_run_topologyrandom \
95 test_testbed_api_testbed_run_topologyline \ 95 test_testbed_api_testbed_run_topologyline \
96 test_testbed_api_testbed_run_topologyclique 96 test_testbed_api_testbed_run_topologyclique \
97 test_testbed_api_testbed_run_topologyring
97 98
98if ENABLE_TEST_RUN 99if ENABLE_TEST_RUN
99 TESTS = \ 100 TESTS = \
@@ -110,7 +111,8 @@ if ENABLE_TEST_RUN
110 test_testbed_api_topology_clique \ 111 test_testbed_api_topology_clique \
111 test_testbed_api_testbed_run_topologyrandom \ 112 test_testbed_api_testbed_run_topologyrandom \
112 test_testbed_api_testbed_run_topologyline \ 113 test_testbed_api_testbed_run_topologyline \
113 test_testbed_api_testbed_run_topologyclique 114 test_testbed_api_testbed_run_topologyclique \
115 test_testbed_api_testbed_run_topologyring
114endif 116endif
115 117
116test_testbed_api_hosts_SOURCES = \ 118test_testbed_api_hosts_SOURCES = \
@@ -202,9 +204,15 @@ test_testbed_api_testbed_run_topologyclique_LDADD = \
202 $(top_builddir)/src/util/libgnunetutil.la \ 204 $(top_builddir)/src/util/libgnunetutil.la \
203 libgnunettestbed.la 205 libgnunettestbed.la
204 206
207test_testbed_api_testbed_run_topologyring_SOURCES = \
208 test_testbed_api_testbed_run.c
209test_testbed_api_testbed_run_topologyring_LDADD = \
210 $(top_builddir)/src/util/libgnunetutil.la \
211 libgnunettestbed.la
205 212
206EXTRA_DIST = \ 213EXTRA_DIST = \
207 test_testbed_api.conf \ 214 test_testbed_api.conf \
215 test_testbed_api_testbed_run_topologyring.conf \
208 test_testbed_api_testbed_run_topologyclique.conf \ 216 test_testbed_api_testbed_run_topologyclique.conf \
209 test_testbed_api_testbed_run_topologyline.conf \ 217 test_testbed_api_testbed_run_topologyline.conf \
210 test_testbed_api_testbed_run_topologyrandom.conf \ 218 test_testbed_api_testbed_run_topologyrandom.conf \