aboutsummaryrefslogtreecommitdiff
path: root/src/testbed/Makefile.am
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2013-02-18 16:24:52 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2013-02-18 16:24:52 +0000
commita424ca9670fcd6d5bf9c67c24142f3615a283706 (patch)
tree2320fb94e5d11e0e87e5f853030b5c785cf243b6 /src/testbed/Makefile.am
parentb32d9a1c4fbec97fe4c59612ed1596b7227ac25b (diff)
downloadgnunet-a424ca9670fcd6d5bf9c67c24142f3615a283706.tar.gz
gnunet-a424ca9670fcd6d5bf9c67c24142f3615a283706.zip
- rename and install to bin
Diffstat (limited to 'src/testbed/Makefile.am')
-rw-r--r--src/testbed/Makefile.am24
1 files changed, 11 insertions, 13 deletions
diff --git a/src/testbed/Makefile.am b/src/testbed/Makefile.am
index 26b576deb..53a90c325 100644
--- a/src/testbed/Makefile.am
+++ b/src/testbed/Makefile.am
@@ -10,12 +10,11 @@ if USE_COVERAGE
10endif 10endif
11 11
12if WITH_LL 12if WITH_LL
13 CC = mpcc 13 CC = mpicc
14 ll_noinst_binaries = \
15 ll-master \
16 ll-monitor
17 ll_binaries = \ 14 ll_binaries = \
18 gnunet-mpi-test 15 gnunet-mpi-test \
16 gnunet-testbed-ll-master \
17 gnunet-testbed-ll-monitor
19endif 18endif
20 19
21libexecdir= $(pkglibdir)/libexec/ 20libexecdir= $(pkglibdir)/libexec/
@@ -33,8 +32,7 @@ bin_PROGRAMS = \
33 $(ll_binaries) 32 $(ll_binaries)
34 33
35noinst_PROGRAMS = \ 34noinst_PROGRAMS = \
36 gnunet-testbed-profiler \ 35 gnunet-testbed-profiler
37 $(ll_noinst_binaries)
38 36
39gnunet_service_testbed_SOURCES = \ 37gnunet_service_testbed_SOURCES = \
40 gnunet-service-testbed.c \ 38 gnunet-service-testbed.c \
@@ -69,15 +67,15 @@ gnunet_helper_testbed_DEPENDENCIES = \
69 gnunet-service-testbed.$(OBJEXT) \ 67 gnunet-service-testbed.$(OBJEXT) \
70 libgnunettestbed.la 68 libgnunettestbed.la
71 69
72ll_master_SOURCES = \ 70gnunet_testbed_ll_master_SOURCES = \
73 ll_master.c 71 gnunet_testbed_ll_master.c
74ll_master_LDADD = $(XLIB) \ 72gnunet_testbed_ll_master_LDADD = $(XLIB) \
75 $(top_builddir)/src/util/libgnunetutil.la \ 73 $(top_builddir)/src/util/libgnunetutil.la \
76 $(LTLIBINTL) -lz -lllapi 74 $(LTLIBINTL) -lz -lllapi
77 75
78ll_monitor_SOURCES = \ 76gnunet_testbed_ll_monitor_SOURCES = \
79 ll_monitor.c 77 gnunet_testbed_ll_monitor.c
80ll_monitor_LDADD = $(XLIB) \ 78gnunet_testbed_ll_monitor_LDADD = $(XLIB) \
81 $(LTLIBINTL) -lz -lllapi 79 $(LTLIBINTL) -lz -lllapi
82 80
83gnunet_mpi_test_SOURCES = gnunet_mpi_test.c 81gnunet_mpi_test_SOURCES = gnunet_mpi_test.c