aboutsummaryrefslogtreecommitdiff
path: root/src/testbed/Makefile.am
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2013-03-15 09:37:18 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2013-03-15 09:37:18 +0000
commitb92fefc699df523441c3b24d6d59cdc016af6bac (patch)
tree6710e2c32918af8d0f780f655acd5a1727f1fffa /src/testbed/Makefile.am
parentfef4792abec19870be63c7922ada0ebd4397a7c1 (diff)
downloadgnunet-b92fefc699df523441c3b24d6d59cdc016af6bac.tar.gz
gnunet-b92fefc699df523441c3b24d6d59cdc016af6bac.zip
Call TestMaster callback upon timeout set through configuration
fixes #2833
Diffstat (limited to 'src/testbed/Makefile.am')
-rw-r--r--src/testbed/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/testbed/Makefile.am b/src/testbed/Makefile.am
index bc703ebcb..8b5cfbd9f 100644
--- a/src/testbed/Makefile.am
+++ b/src/testbed/Makefile.am
@@ -109,6 +109,7 @@ check_PROGRAMS = \
109 test_testbed_api_operations \ 109 test_testbed_api_operations \
110 test_testbed_api_testbed_run \ 110 test_testbed_api_testbed_run \
111 test_testbed_api_test \ 111 test_testbed_api_test \
112 test_testbed_api_test_timeout \
112 test_gnunet_helper_testbed \ 113 test_gnunet_helper_testbed \
113 test_testbed_api_topology \ 114 test_testbed_api_topology \
114 test_testbed_api_topology_clique \ 115 test_testbed_api_topology_clique \
@@ -135,6 +136,7 @@ if ENABLE_TEST_RUN
135 test_testbed_api_3peers_3controllers \ 136 test_testbed_api_3peers_3controllers \
136 test_testbed_api_testbed_run \ 137 test_testbed_api_testbed_run \
137 test_testbed_api_test \ 138 test_testbed_api_test \
139 test_testbed_api_test_timeout \
138 test_testbed_api_statistics \ 140 test_testbed_api_statistics \
139 test_testbed_api_topology \ 141 test_testbed_api_topology \
140 test_testbed_api_topology_clique \ 142 test_testbed_api_topology_clique \
@@ -207,6 +209,12 @@ test_testbed_api_test_LDADD = \
207 $(top_builddir)/src/util/libgnunetutil.la \ 209 $(top_builddir)/src/util/libgnunetutil.la \
208 libgnunettestbed.la 210 libgnunettestbed.la
209 211
212test_testbed_api_test_timeout_SOURCES = \
213 test_testbed_api_test_timeout.c
214test_testbed_api_test_timeout_LDADD = \
215 $(top_builddir)/src/util/libgnunetutil.la \
216 libgnunettestbed.la
217
210test_testbed_api_topology_SOURCES = \ 218test_testbed_api_topology_SOURCES = \
211 test_testbed_api_topology.c 219 test_testbed_api_topology.c
212test_testbed_api_topology_LDADD = \ 220test_testbed_api_topology_LDADD = \
@@ -288,6 +296,7 @@ test_testbed_api_statistics_LDADD = \
288 296
289EXTRA_DIST = \ 297EXTRA_DIST = \
290 test_testbed_api.conf \ 298 test_testbed_api.conf \
299 test_testbed_api_test_timeout.conf \
291 test_testbed_api_testbed_run_topologyring.conf \ 300 test_testbed_api_testbed_run_topologyring.conf \
292 test_testbed_api_testbed_run_topologyclique.conf \ 301 test_testbed_api_testbed_run_topologyclique.conf \
293 test_testbed_api_testbed_run_topologyline.conf \ 302 test_testbed_api_testbed_run_topologyline.conf \