aboutsummaryrefslogtreecommitdiff
path: root/src/testbed/Makefile.am
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2012-10-22 20:52:27 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2012-10-22 20:52:27 +0000
commitbd9f50c4923d523fdd3494a174b12a4926335149 (patch)
tree945e306f9f6d095c7bee5456ebc05b5d97aefbed /src/testbed/Makefile.am
parenta15908504806fee9b8225070d11fc2f01dbd2b05 (diff)
downloadgnunet-bd9f50c4923d523fdd3494a174b12a4926335149.tar.gz
gnunet-bd9f50c4923d523fdd3494a174b12a4926335149.zip
clique topology
Diffstat (limited to 'src/testbed/Makefile.am')
-rw-r--r--src/testbed/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/testbed/Makefile.am b/src/testbed/Makefile.am
index ec371e59d..e37d0ce11 100644
--- a/src/testbed/Makefile.am
+++ b/src/testbed/Makefile.am
@@ -87,7 +87,8 @@ check_PROGRAMS = \
87 test_testbed_api_testbed_run \ 87 test_testbed_api_testbed_run \
88 test_testbed_api_test \ 88 test_testbed_api_test \
89 test_gnunet_helper_testbed \ 89 test_gnunet_helper_testbed \
90 test_testbed_api_topology 90 test_testbed_api_topology \
91 test_testbed_api_topology_clique
91 92
92if ENABLE_TEST_RUN 93if ENABLE_TEST_RUN
93 TESTS = \ 94 TESTS = \
@@ -100,7 +101,8 @@ if ENABLE_TEST_RUN
100 test_testbed_api_controllerlink \ 101 test_testbed_api_controllerlink \
101 test_testbed_api_testbed_run \ 102 test_testbed_api_testbed_run \
102 test_testbed_api_test \ 103 test_testbed_api_test \
103 test_testbed_api_topology 104 test_testbed_api_topology \
105 test_testbed_api_topology_clique
104endif 106endif
105 107
106test_testbed_api_hosts_SOURCES = \ 108test_testbed_api_hosts_SOURCES = \
@@ -161,6 +163,12 @@ test_testbed_api_topology_LDADD = \
161 $(top_builddir)/src/util/libgnunetutil.la \ 163 $(top_builddir)/src/util/libgnunetutil.la \
162 libgnunettestbed.la 164 libgnunettestbed.la
163 165
166test_testbed_api_topology_clique_SOURCES = \
167 test_testbed_api_topology_clique.c
168test_testbed_api_topology_clique_LDADD = \
169 $(top_builddir)/src/util/libgnunetutil.la \
170 libgnunettestbed.la
171
164test_gnunet_helper_testbed_SOURCES = \ 172test_gnunet_helper_testbed_SOURCES = \
165 test_gnunet_helper_testbed.c 173 test_gnunet_helper_testbed.c
166test_gnunet_helper_testbed_LDADD = \ 174test_gnunet_helper_testbed_LDADD = \