aboutsummaryrefslogtreecommitdiff
path: root/src/testbed/Makefile.am
diff options
context:
space:
mode:
authorSree Harsha Totakura <totakura@in.tum.de>2012-11-12 18:13:55 +0000
committerSree Harsha Totakura <totakura@in.tum.de>2012-11-12 18:13:55 +0000
commitcd07db057216ad47693bde4c38b45013628465b0 (patch)
treecd52fb1986c6b051bf5b67517de2700cf8478869 /src/testbed/Makefile.am
parent61a51d59b76d8c0ab20e06314e7c2581a2b595a1 (diff)
downloadgnunet-cd07db057216ad47693bde4c38b45013628465b0.tar.gz
gnunet-cd07db057216ad47693bde4c38b45013628465b0.zip
implementing small world ring topology
Diffstat (limited to 'src/testbed/Makefile.am')
-rw-r--r--src/testbed/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/src/testbed/Makefile.am b/src/testbed/Makefile.am
index 9eee7cf4e..a48fd138f 100644
--- a/src/testbed/Makefile.am
+++ b/src/testbed/Makefile.am
@@ -94,7 +94,8 @@ check_PROGRAMS = \
94 test_testbed_api_testbed_run_topologyrandom \ 94 test_testbed_api_testbed_run_topologyrandom \
95 test_testbed_api_testbed_run_topologyline \ 95 test_testbed_api_testbed_run_topologyline \
96 test_testbed_api_testbed_run_topologyclique \ 96 test_testbed_api_testbed_run_topologyclique \
97 test_testbed_api_testbed_run_topologyring 97 test_testbed_api_testbed_run_topologyring \
98 test_testbed_api_testbed_run_topologysmallworldring
98 99
99if ENABLE_TEST_RUN 100if ENABLE_TEST_RUN
100 TESTS = \ 101 TESTS = \
@@ -112,7 +113,8 @@ if ENABLE_TEST_RUN
112 test_testbed_api_testbed_run_topologyrandom \ 113 test_testbed_api_testbed_run_topologyrandom \
113 test_testbed_api_testbed_run_topologyline \ 114 test_testbed_api_testbed_run_topologyline \
114 test_testbed_api_testbed_run_topologyclique \ 115 test_testbed_api_testbed_run_topologyclique \
115 test_testbed_api_testbed_run_topologyring 116 test_testbed_api_testbed_run_topologyring \
117 test_testbed_api_testbed_run_topologysmallworldring
116endif 118endif
117 119
118test_testbed_api_hosts_SOURCES = \ 120test_testbed_api_hosts_SOURCES = \
@@ -210,10 +212,17 @@ test_testbed_api_testbed_run_topologyring_LDADD = \
210 $(top_builddir)/src/util/libgnunetutil.la \ 212 $(top_builddir)/src/util/libgnunetutil.la \
211 libgnunettestbed.la 213 libgnunettestbed.la
212 214
215test_testbed_api_testbed_run_topologysmallworldring_SOURCES = \
216 test_testbed_api_testbed_run.c
217test_testbed_api_testbed_run_topologysmallworldring_LDADD = \
218 $(top_builddir)/src/util/libgnunetutil.la \
219 libgnunettestbed.la
220
213EXTRA_DIST = \ 221EXTRA_DIST = \
214 test_testbed_api.conf \ 222 test_testbed_api.conf \
215 test_testbed_api_testbed_run_topologyring.conf \ 223 test_testbed_api_testbed_run_topologyring.conf \
216 test_testbed_api_testbed_run_topologyclique.conf \ 224 test_testbed_api_testbed_run_topologyclique.conf \
217 test_testbed_api_testbed_run_topologyline.conf \ 225 test_testbed_api_testbed_run_topologyline.conf \
218 test_testbed_api_testbed_run_topologyrandom.conf \ 226 test_testbed_api_testbed_run_topologyrandom.conf \
227 test_testbed_api_testbed_run_topologysmallworldring.conf \
219 sample_hosts.txt \ No newline at end of file 228 sample_hosts.txt \ No newline at end of file