aboutsummaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-05-03 16:52:54 +0000
committerChristian Grothoff <christian@grothoff.org>2012-05-03 16:52:54 +0000
commit0ab4af1ee46c38dfde4052de5570486abc2ad4fd (patch)
treeccc0f7c04597f04e7965dbb6c2ba8dc9c8e72b0a /src/testing/Makefile.am
parent57d66a199ad1a718e16c1f3719fd75835104845f (diff)
downloadgnunet-0ab4af1ee46c38dfde4052de5570486abc2ad4fd.tar.gz
gnunet-0ab4af1ee46c38dfde4052de5570486abc2ad4fd.zip
-fix compilation of new testing draft
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am24
1 files changed, 23 insertions, 1 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
index 47a4e1bd0..9dfe66b92 100644
--- a/src/testing/Makefile.am
+++ b/src/testing/Makefile.am
@@ -33,7 +33,29 @@ if HAVE_EXPENSIVE_TESTS
33 test_testing_topology_scale_free 33 test_testing_topology_scale_free
34endif 34endif
35 35
36lib_LTLIBRARIES = libgnunettesting.la 36lib_LTLIBRARIES = \
37 libgnunettesting.la \
38 libgnunettesting_new.la
39
40libgnunettesting_new_la_SOURCES = \
41 new_testing_api.c new_testing.h \
42 new_testing_api_hosts.c new_testing_api_hosts.h \
43 new_testing_api_operations.c new_testing_api_operations.h \
44 new_testing_api_peers.c new_testing_api_peers.h \
45 new_testing_api_services.c \
46 new_testing_api_testbed.c \
47 new_testing_api_test.c \
48 new_testing_api_topology.c
49libgnunettesting_new_la_LIBADD = $(XLIB) \
50 $(top_builddir)/src/core/libgnunetcore.la \
51 $(top_builddir)/src/statistics/libgnunetstatistics.la \
52 $(top_builddir)/src/transport/libgnunettransport.la \
53 $(top_builddir)/src/hello/libgnunethello.la \
54 -lm \
55 $(top_builddir)/src/util/libgnunetutil.la
56libgnunettesting_new_la_LDFLAGS = \
57 $(GN_LIB_LDFLAGS) \
58 -version-info 0:0:0
37 59
38libgnunettesting_la_SOURCES = \ 60libgnunettesting_la_SOURCES = \
39 helper.c \ 61 helper.c \