aboutsummaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-05-05 17:57:02 +0000
committerChristian Grothoff <christian@grothoff.org>2012-05-05 17:57:02 +0000
commit8e4c75f917ce5aa92eb0b39eef44aaffac3a0a27 (patch)
treeb85846925fd25a2a87e7e1dc397d4844d0eb2049 /src/testing/Makefile.am
parent65f3c726359d3c60c760b3c116ec7c5ab97f5e5d (diff)
downloadgnunet-8e4c75f917ce5aa92eb0b39eef44aaffac3a0a27.tar.gz
gnunet-8e4c75f917ce5aa92eb0b39eef44aaffac3a0a27.zip
-draft of new low-level testing API
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
index 4f6f90c4d..7c0f289c9 100644
--- a/src/testing/Makefile.am
+++ b/src/testing/Makefile.am
@@ -34,7 +34,8 @@ if HAVE_EXPENSIVE_TESTS
34endif 34endif
35 35
36lib_LTLIBRARIES = \ 36lib_LTLIBRARIES = \
37 libgnunettesting.la 37 libgnunettesting.la \
38 libgnunettesting_new.la
38 39
39libgnunettesting_la_SOURCES = \ 40libgnunettesting_la_SOURCES = \
40 helper.c \ 41 helper.c \
@@ -52,6 +53,16 @@ libgnunettesting_la_LDFLAGS = \
52 $(GN_LIB_LDFLAGS) \ 53 $(GN_LIB_LDFLAGS) \
53 -version-info 0:1:0 54 -version-info 0:1:0
54 55
56
57libgnunettesting_new_la_SOURCES = \
58 testing_new.c
59libgnunettesting_new_la_LIBADD = \
60 $(top_builddir)/src/util/libgnunetutil.la
61libgnunettesting_new_la_LDFLAGS = \
62 $(GN_LIB_LDFLAGS) \
63 -version-info 0:1:0
64
65
55bin_PROGRAMS = \ 66bin_PROGRAMS = \
56 gnunet-testing 67 gnunet-testing
57 68