aboutsummaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2009-06-18 02:21:46 +0000
committerChristian Grothoff <christian@grothoff.org>2009-06-18 02:21:46 +0000
commitd5e417f094cac294282deafe46409342796263c6 (patch)
tree0f050bb7602193a9e829d2727171fbccf9b03e6a /src/testing/Makefile.am
parentc3ca725eb3c48d1f1726d3abd2c9816af924d222 (diff)
downloadgnunet-d5e417f094cac294282deafe46409342796263c6.tar.gz
gnunet-d5e417f094cac294282deafe46409342796263c6.zip
testing-design
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
new file mode 100644
index 000000000..4d25d8b44
--- /dev/null
+++ b/src/testing/Makefile.am
@@ -0,0 +1,30 @@
1INCLUDES = -I$(top_srcdir)/src/include
2
3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5endif
6
7if USE_COVERAGE
8 AM_CFLAGS = --coverage -O0
9 XLIB = -lgcov
10endif
11
12lib_LTLIBRARIES = libgnunettesting.la
13
14libgnunettesting_la_SOURCES = \
15 testing.c \
16 testing_testbed.c
17libgnunettesting_la_LIBADD = \
18 $(top_builddir)/src/util/libgnunetutil.la $(XLIB)
19
20#check_PROGRAMS = \
21# test_testing
22#
23#TESTS = $(check_PROGRAMS)
24#
25#test_testing_SOURCES = \
26# test_testing.c
27#test_testing_LDADD = \
28# $(top_builddir)/src/testing/libgnunettesting.la \
29# $(top_builddir)/src/util/libgnunetutil.la
30