aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authort3sserakt <t3ss@posteo.de>2021-01-25 15:47:10 +0100
committert3sserakt <t3ss@posteo.de>2021-01-25 15:47:10 +0100
commitac71165822501c42b00980db2fb7f5e2144f3d20 (patch)
treecb62e4f7af0f91bdcf50c69bfc0bb901d3059358 /src/transport/Makefile.am
parent438aca2f666f0e0648f389774adee01c131da25c (diff)
downloadgnunet-ac71165822501c42b00980db2fb7f5e2144f3d20.tar.gz
gnunet-ac71165822501c42b00980db2fb7f5e2144f3d20.zip
- fixed bug in tcp com challenge logic. added test case for bidirectional test.
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index a2fc3811e..0251b001e 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -618,7 +618,8 @@ check_PROGRAMS += \
618 test_communicator_basic-udp \ 618 test_communicator_basic-udp \
619 test_communicator_rekey-tcp \ 619 test_communicator_rekey-tcp \
620 test_communicator_rekey-udp \ 620 test_communicator_rekey-udp \
621 test_communicator_backchannel-udp 621 test_communicator_backchannel-udp \
622 test_communicator_bidirect-tcp
622endif 623endif
623endif 624endif
624 625
@@ -696,7 +697,8 @@ TESTS += \
696 test_communicator_basic-udp \ 697 test_communicator_basic-udp \
697 test_communicator_rekey-tcp \ 698 test_communicator_rekey-tcp \
698 test_communicator_rekey-udp \ 699 test_communicator_rekey-udp \
699 test_communicator_backchannel-udp 700 test_communicator_backchannel-udp \
701 test_communicator_bidirect-tcp
700endif 702endif
701endif 703endif
702 704
@@ -857,6 +859,14 @@ test_communicator_backchannel_udp_LDADD = \
857 $(top_builddir)/src/testing/libgnunettesting.la \ 859 $(top_builddir)/src/testing/libgnunettesting.la \
858 $(top_builddir)/src/util/libgnunetutil.la \ 860 $(top_builddir)/src/util/libgnunetutil.la \
859 $(top_builddir)/src/statistics/libgnunetstatistics.la 861 $(top_builddir)/src/statistics/libgnunetstatistics.la
862
863test_communicator_bidirect_tcp_SOURCES = \
864 test_communicator_basic.c
865test_communicator_bidirect_tcp_LDADD = \
866 libgnunettransporttesting2.la \
867 $(top_builddir)/src/testing/libgnunettesting.la \
868 $(top_builddir)/src/util/libgnunetutil.la \
869 $(top_builddir)/src/statistics/libgnunetstatistics.la
860endif 870endif
861 871
862test_plugin_unix_SOURCES = \ 872test_plugin_unix_SOURCES = \
@@ -1567,4 +1577,6 @@ test_communicator_tcp_rekey_peer2.conf \
1567test_communicator_udp_rekey_peer1.conf \ 1577test_communicator_udp_rekey_peer1.conf \
1568test_communicator_udp_rekey_peer2.conf \ 1578test_communicator_udp_rekey_peer2.conf \
1569test_communicator_udp_backchannel_peer1.conf \ 1579test_communicator_udp_backchannel_peer1.conf \
1570test_communicator_udp_backchannel_peer2.conf 1580test_communicator_udp_backchannel_peer2.conf \
1581test_communicator_tcp_bidirect_peer1.conf \
1582test_communicator_tcp_bidirect_peer2.conf