aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2019-12-26 14:51:50 +0900
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2019-12-26 14:51:50 +0900
commit4b9bda397d8988d6a4e2f3f009c2157fc35a305a (patch)
tree87497dabafc8dd80c27e4c080d5e5891509456bc /src/transport/Makefile.am
parent4f331dcb694ec0241093e8a46d82ac8ce6537219 (diff)
downloadgnunet-4b9bda397d8988d6a4e2f3f009c2157fc35a305a.tar.gz
gnunet-4b9bda397d8988d6a4e2f3f009c2157fc35a305a.zip
add udp comm test case
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index e35b6bb3f..e037f3001 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -597,7 +597,8 @@ check_PROGRAMS += \
597 test_transport_api_reliability_udp \ 597 test_transport_api_reliability_udp \
598 test_quota_compliance_udp \ 598 test_quota_compliance_udp \
599 test_communicator_basic_unix \ 599 test_communicator_basic_unix \
600 test_communicator_basic_tcp 600 test_communicator_basic_tcp \
601 test_communicator_basic_udp
601endif 602endif
602endif 603endif
603 604
@@ -796,6 +797,13 @@ test_communicator_basic_tcp_LDADD = \
796 libgnunettransporttesting2.la \ 797 libgnunettransporttesting2.la \
797 $(top_builddir)/src/testing/libgnunettesting.la \ 798 $(top_builddir)/src/testing/libgnunettesting.la \
798 $(top_builddir)/src/util/libgnunetutil.la 799 $(top_builddir)/src/util/libgnunetutil.la
800
801test_communicator_basic_udp_SOURCES = \
802 test_communicator_basic.c
803test_communicator_basic_udp_LDADD = \
804 libgnunettransporttesting2.la \
805 $(top_builddir)/src/testing/libgnunettesting.la \
806 $(top_builddir)/src/util/libgnunetutil.la
799endif 807endif
800 808
801test_plugin_unix_SOURCES = \ 809test_plugin_unix_SOURCES = \
@@ -1498,4 +1506,6 @@ test_transport_api_slow_ats_peer2.conf \
1498test_communicator_unix_peer1.conf \ 1506test_communicator_unix_peer1.conf \
1499test_communicator_unix_peer2.conf \ 1507test_communicator_unix_peer2.conf \
1500test_communicator_tcp_peer1.conf \ 1508test_communicator_tcp_peer1.conf \
1501test_communicator_tcp_peer2.conf 1509test_communicator_tcp_peer2.conf \
1510test_communicator_udp_peer1.conf \
1511test_communicator_udp_peer2.conf