aboutsummaryrefslogtreecommitdiff
path: root/src/tun/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2013-06-20 08:32:50 +0000
committerChristian Grothoff <christian@grothoff.org>2013-06-20 08:32:50 +0000
commit21a2b4f95b4488645ba5a6254fcb8919c4915f73 (patch)
tree00c92cb7103cc14fba7e63e8dee99fe711856863 /src/tun/Makefile.am
parent5533b105943b4f6dd688c1758350cd83ebeab3b9 (diff)
downloadgnunet-21a2b4f95b4488645ba5a6254fcb8919c4915f73.tar.gz
gnunet-21a2b4f95b4488645ba5a6254fcb8919c4915f73.zip
continuing refactoring of regex library structure, disambiguating symbol names between old regex library which is now internal and the public API; moving IP-to-regex conversion functions to tun library, as only vpn is using those to begin with
Diffstat (limited to 'src/tun/Makefile.am')
-rw-r--r--src/tun/Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/src/tun/Makefile.am b/src/tun/Makefile.am
index 3b2b573b6..96e79d0d8 100644
--- a/src/tun/Makefile.am
+++ b/src/tun/Makefile.am
@@ -12,18 +12,19 @@ endif
12lib_LTLIBRARIES = libgnunettun.la 12lib_LTLIBRARIES = libgnunettun.la
13 13
14libgnunettun_la_SOURCES = \ 14libgnunettun_la_SOURCES = \
15 tun.c 15 tun.c \
16 regex.c
16libgnunettun_la_LIBADD = \ 17libgnunettun_la_LIBADD = \
17 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \ 18 $(top_builddir)/src/util/libgnunetutil.la $(XLIB) \
18 $(LTLIBINTL) 19 $(LTLIBINTL)
19libgnunettun_la_LDFLAGS = \ 20libgnunettun_la_LDFLAGS = \
20 $(GN_LIB_LDFLAGS) \ 21 $(GN_LIB_LDFLAGS) \
21 -version-info 0:0:0 22 -version-info 1:0:1
22 23
23 24
24check_PROGRAMS = \ 25check_PROGRAMS = \
25 test_tun 26 test_tun \
26 27 test_regex
27 28
28if ENABLE_TEST_RUN 29if ENABLE_TEST_RUN
29TESTS = $(check_PROGRAMS) 30TESTS = $(check_PROGRAMS)
@@ -34,3 +35,10 @@ test_tun_SOURCES = \
34test_tun_LDADD = \ 35test_tun_LDADD = \
35 $(top_builddir)/src/util/libgnunetutil.la \ 36 $(top_builddir)/src/util/libgnunetutil.la \
36 $(top_builddir)/src/tun/libgnunettun.la 37 $(top_builddir)/src/tun/libgnunettun.la
38
39
40test_regex_SOURCES = \
41 test_regex.c
42test_regex_LDADD = \
43 $(top_builddir)/src/util/libgnunetutil.la \
44 $(top_builddir)/src/tun/libgnunettun.la