aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorJeff Burdges <burdges@gnunet.org>2016-05-30 16:08:03 +0000
committerJeff Burdges <burdges@gnunet.org>2016-05-30 16:08:03 +0000
commit0c9e498f3d07a285e1a3db51a1c6f1049f022362 (patch)
tree2fd81392ee91b25b92ee73a1c59e2c597ce640be /src/util/Makefile.am
parentafb40a6d7a49d2608b709d6e8863675a6a301c99 (diff)
downloadgnunet-0c9e498f3d07a285e1a3db51a1c6f1049f022362.tar.gz
gnunet-0c9e498f3d07a285e1a3db51a1c6f1049f022362.zip
Testcases for KDF mod n
Currently just that the result is smaller than n, maybe should do more.
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 22471ffda..fe8ab01ea 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -283,6 +283,7 @@ check_PROGRAMS = \
283 test_crypto_hash \ 283 test_crypto_hash \
284 test_crypto_hash_context \ 284 test_crypto_hash_context \
285 test_crypto_hkdf \ 285 test_crypto_hkdf \
286 test_crypto_kdf \
286 test_crypto_paillier \ 287 test_crypto_paillier \
287 test_crypto_random \ 288 test_crypto_random \
288 test_crypto_rsa \ 289 test_crypto_rsa \
@@ -468,6 +469,11 @@ test_crypto_hkdf_SOURCES = \
468test_crypto_hkdf_LDADD = \ 469test_crypto_hkdf_LDADD = \
469 libgnunetutil.la 470 libgnunetutil.la
470 471
472test_crypto_kdf_SOURCES = \
473 test_crypto_kdf.c
474test_crypto_kdf_LDADD = \
475 libgnunetutil.la -lgcrypt
476
471test_crypto_paillier_SOURCES = \ 477test_crypto_paillier_SOURCES = \
472 test_crypto_paillier.c 478 test_crypto_paillier.c
473test_crypto_paillier_LDADD = \ 479test_crypto_paillier_LDADD = \