aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-02-15 18:58:50 +0000
committerng0 <ng0@n0.is>2019-02-15 18:58:50 +0000
commit5efd17d8d54edd201929f3a992ff6ceb20e676ce (patch)
treefadb3d661a9516fd2d713ccac3e26f92d9d3b4a3 /src/util/Makefile.am
parentc2d19c88745d16e5f2a33ad9e291a9d3ab6fa461 (diff)
downloadgnunet-5efd17d8d54edd201929f3a992ff6ceb20e676ce.tar.gz
gnunet-5efd17d8d54edd201929f3a992ff6ceb20e676ce.zip
Fix bug reported by schanzen@ where bootstrap is not enough for our python2.7 script.
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 1e82ec73a..0ba06f4bb 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -225,10 +225,13 @@ gnunet_timeout_SOURCES = \
225 gnunet-timeout-w32.c 225 gnunet-timeout-w32.c
226endif 226endif
227 227
228# This is horrible, but compared to the alternatives and the solution
229# which preceded this it is a good compromise and good enough for one
230# file. Everyone else is invited to patch it locally.
228 231
229mypython27=$(shell cat $(top_srcdir)/src/util/python27_location) 232xENV=$(shell which env)
230 233
231do_subst = $(SED) -e 's,[@]PYTHON2[@],${mypython27},g' 234do_subst = $(SED) -e 's,[@]ENV[@],${xENV},g'
232 235
233gnunet-qr: gnunet-qr.py.in Makefile 236gnunet-qr: gnunet-qr.py.in Makefile
234 $(do_subst) < $(top_srcdir)/src/util/gnunet-qr.py.in > gnunet-qr 237 $(do_subst) < $(top_srcdir)/src/util/gnunet-qr.py.in > gnunet-qr