aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2017-07-08 18:30:01 +0200
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2017-07-08 18:30:01 +0200
commit9d601af559af4e7ad7ed818da499fa22ebfa5ae6 (patch)
treefd13071285ad1d50dd26821a312ab3fc226ee4f7 /src/util/Makefile.am
parent4e2fafb606f98f71aa404b9d0a55bc3b39f90418 (diff)
downloadgnunet-9d601af559af4e7ad7ed818da499fa22ebfa5ae6.tar.gz
gnunet-9d601af559af4e7ad7ed818da499fa22ebfa5ae6.zip
-add ABE crypto module
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 9be572bb6..4b1e44503 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -87,6 +87,7 @@ libgnunetutil_la_SOURCES = \
87 crypto_paillier.c \ 87 crypto_paillier.c \
88 crypto_random.c \ 88 crypto_random.c \
89 crypto_rsa.c \ 89 crypto_rsa.c \
90 crypto_abe.c \
90 disk.c \ 91 disk.c \
91 disk.h \ 92 disk.h \
92 getopt.c \ 93 getopt.c \
@@ -117,12 +118,20 @@ libgnunetutil_la_LIBADD = \
117 $(LIBGCRYPT_LIBS) \ 118 $(LIBGCRYPT_LIBS) \
118 $(LTLIBICONV) \ 119 $(LTLIBICONV) \
119 $(LTLIBINTL) \ 120 $(LTLIBINTL) \
121 $(ABE_LIBADD) \
122 -lbswabe \
123 -lssl \
124 -lpbc \
125 -lglib-2.0 \
120 -lltdl $(Z_LIBS) -lunistring $(XLIB) 126 -lltdl $(Z_LIBS) -lunistring $(XLIB)
121 127
122libgnunetutil_la_LDFLAGS = \ 128libgnunetutil_la_LDFLAGS = \
123 $(GN_LIB_LDFLAGS) \ 129 $(GN_LIB_LDFLAGS) \
130 $(ABE_LDADD) \
124 -version-info 13:0:0 131 -version-info 13:0:0
125 132
133libgnunetutil_la_CFLAGS = \
134 $(ABE_CFLAGS)
126 135
127libgnunetutil_taler_wallet_la_SOURCES = \ 136libgnunetutil_taler_wallet_la_SOURCES = \
128 common_allocation.c \ 137 common_allocation.c \
@@ -274,6 +283,7 @@ check_PROGRAMS = \
274 test_container_multipeermap \ 283 test_container_multipeermap \
275 test_container_heap \ 284 test_container_heap \
276 test_crypto_symmetric \ 285 test_crypto_symmetric \
286 test_crypto_abe \
277 test_crypto_crc \ 287 test_crypto_crc \
278 test_crypto_ecdsa \ 288 test_crypto_ecdsa \
279 test_crypto_eddsa \ 289 test_crypto_eddsa \
@@ -406,6 +416,11 @@ test_crypto_symmetric_SOURCES = \
406test_crypto_symmetric_LDADD = \ 416test_crypto_symmetric_LDADD = \
407 libgnunetutil.la 417 libgnunetutil.la
408 418
419test_crypto_abe_SOURCES = \
420 test_crypto_abe.c
421test_crypto_abe_LDADD = \
422 libgnunetutil.la
423
409test_crypto_crc_SOURCES = \ 424test_crypto_crc_SOURCES = \
410 test_crypto_crc.c 425 test_crypto_crc.c
411test_crypto_crc_LDADD = \ 426test_crypto_crc_LDADD = \