aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-09-28 13:22:21 +0000
committerChristian Grothoff <christian@grothoff.org>2015-09-28 13:22:21 +0000
commit2b70eeaf2bce2c777198d91c5a8357c2426540a0 (patch)
treec7bb436fde68f5dbe86fc05d00cb8d9a2b0084ed /src/util/Makefile.am
parentcab1b047ddcac497e14515fc11f097c4aac8ee27 (diff)
downloadgnunet-2b70eeaf2bce2c777198d91c5a8357c2426540a0.tar.gz
gnunet-2b70eeaf2bce2c777198d91c5a8357c2426540a0.zip
add ecc dlog benchmark
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 90a0717ab..896ef17eb 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -248,6 +248,7 @@ libgnunet_plugin_test_la_LDFLAGS = \
248if HAVE_BENCHMARKS 248if HAVE_BENCHMARKS
249 BENCHMARKS = \ 249 BENCHMARKS = \
250 perf_crypto_hash \ 250 perf_crypto_hash \
251 perf_crypto_ecc_dlog \
251 perf_crypto_rsa \ 252 perf_crypto_rsa \
252 perf_crypto_paillier \ 253 perf_crypto_paillier \
253 perf_crypto_symmetric \ 254 perf_crypto_symmetric \
@@ -627,6 +628,12 @@ perf_crypto_hash_SOURCES = \
627perf_crypto_hash_LDADD = \ 628perf_crypto_hash_LDADD = \
628 libgnunetutil.la 629 libgnunetutil.la
629 630
631perf_crypto_ecc_dlog_SOURCES = \
632 perf_crypto_ecc_dlog.c
633perf_crypto_ecc_dlog_LDADD = \
634 libgnunetutil.la \
635 -lgcrypt
636
630perf_crypto_rsa_SOURCES = \ 637perf_crypto_rsa_SOURCES = \
631 perf_crypto_rsa.c 638 perf_crypto_rsa.c
632perf_crypto_rsa_LDADD = \ 639perf_crypto_rsa_LDADD = \