aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2017-07-14 13:57:51 +0200
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2017-07-14 13:57:51 +0200
commitb6755fe23d258a4dc971d8fabc3fae1873e31271 (patch)
tree669698febb6b5c6e0eff01054752c2a6fe374ddc /src/util/Makefile.am
parent8cb2e0da6845a2edad4be52a2c785715a91f4658 (diff)
downloadgnunet-b6755fe23d258a4dc971d8fabc3fae1873e31271.tar.gz
gnunet-b6755fe23d258a4dc971d8fabc3fae1873e31271.zip
-change to gabe bswabe fork
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am39
1 files changed, 23 insertions, 16 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 4b1e44503..62cf03684 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -87,7 +87,6 @@ libgnunetutil_la_SOURCES = \
87 crypto_paillier.c \ 87 crypto_paillier.c \
88 crypto_random.c \ 88 crypto_random.c \
89 crypto_rsa.c \ 89 crypto_rsa.c \
90 crypto_abe.c \
91 disk.c \ 90 disk.c \
92 disk.h \ 91 disk.h \
93 getopt.c \ 92 getopt.c \
@@ -118,21 +117,24 @@ libgnunetutil_la_LIBADD = \
118 $(LIBGCRYPT_LIBS) \ 117 $(LIBGCRYPT_LIBS) \
119 $(LTLIBICONV) \ 118 $(LTLIBICONV) \
120 $(LTLIBINTL) \ 119 $(LTLIBINTL) \
121 $(ABE_LIBADD) \
122 -lbswabe \
123 -lssl \
124 -lpbc \
125 -lglib-2.0 \
126 -lltdl $(Z_LIBS) -lunistring $(XLIB) 120 -lltdl $(Z_LIBS) -lunistring $(XLIB)
127 121
122if HAVE_PBC
123if HAVE_ABE
124libgnunetutil_la_SOURCES += \
125 crypto_abe.c
126libgnunetutil_la_LIBADD += \
127 $(ABE_LIBADD) \
128 -lgabe \
129 -lpbc \
130 -lglib-2.0
131endif
132endif
133
128libgnunetutil_la_LDFLAGS = \ 134libgnunetutil_la_LDFLAGS = \
129 $(GN_LIB_LDFLAGS) \ 135 $(GN_LIB_LDFLAGS) \
130 $(ABE_LDADD) \
131 -version-info 13:0:0 136 -version-info 13:0:0
132 137
133libgnunetutil_la_CFLAGS = \
134 $(ABE_CFLAGS)
135
136libgnunetutil_taler_wallet_la_SOURCES = \ 138libgnunetutil_taler_wallet_la_SOURCES = \
137 common_allocation.c \ 139 common_allocation.c \
138 common_endian.c \ 140 common_endian.c \
@@ -283,7 +285,6 @@ check_PROGRAMS = \
283 test_container_multipeermap \ 285 test_container_multipeermap \
284 test_container_heap \ 286 test_container_heap \
285 test_crypto_symmetric \ 287 test_crypto_symmetric \
286 test_crypto_abe \
287 test_crypto_crc \ 288 test_crypto_crc \
288 test_crypto_ecdsa \ 289 test_crypto_ecdsa \
289 test_crypto_eddsa \ 290 test_crypto_eddsa \
@@ -416,11 +417,6 @@ test_crypto_symmetric_SOURCES = \
416test_crypto_symmetric_LDADD = \ 417test_crypto_symmetric_LDADD = \
417 libgnunetutil.la 418 libgnunetutil.la
418 419
419test_crypto_abe_SOURCES = \
420 test_crypto_abe.c
421test_crypto_abe_LDADD = \
422 libgnunetutil.la
423
424test_crypto_crc_SOURCES = \ 420test_crypto_crc_SOURCES = \
425 test_crypto_crc.c 421 test_crypto_crc.c
426test_crypto_crc_LDADD = \ 422test_crypto_crc_LDADD = \
@@ -568,6 +564,17 @@ test_speedup_SOURCES = \
568test_speedup_LDADD = \ 564test_speedup_LDADD = \
569 libgnunetutil.la 565 libgnunetutil.la
570 566
567if HAVE_PBC
568if HAVE_ABE
569test_crypto_abe_SOURCES = \
570 test_crypto_abe.c
571test_crypto_abe_LDADD = \
572 libgnunetutil.la
573check_PROGRAMS += \
574 test_crypto_abe
575endif
576endif
577
571perf_crypto_hash_SOURCES = \ 578perf_crypto_hash_SOURCES = \
572 perf_crypto_hash.c 579 perf_crypto_hash.c
573perf_crypto_hash_LDADD = \ 580perf_crypto_hash_LDADD = \