aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-07-02 19:58:35 +0000
committerChristian Grothoff <christian@grothoff.org>2015-07-02 19:58:35 +0000
commitfece22eebf8c8d54e79d05f748019e7234823828 (patch)
treef875095ec8a2918a263f273a71b721654cfba612 /src/util/Makefile.am
parented53a24f07a861edf7edd327c04fc7a23111e3c4 (diff)
downloadgnunet-fece22eebf8c8d54e79d05f748019e7234823828.tar.gz
gnunet-fece22eebf8c8d54e79d05f748019e7234823828.zip
-adding ecc dlog support
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 916a588fa..13a16448b 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -76,6 +76,7 @@ libgnunetutil_la_SOURCES = \
76 crypto_symmetric.c \ 76 crypto_symmetric.c \
77 crypto_crc.c \ 77 crypto_crc.c \
78 crypto_ecc.c \ 78 crypto_ecc.c \
79 crypto_ecc_dlog.c \
79 crypto_ecc_setup.c \ 80 crypto_ecc_setup.c \
80 crypto_hash.c \ 81 crypto_hash.c \
81 crypto_hash_file.c \ 82 crypto_hash_file.c \
@@ -271,6 +272,7 @@ check_PROGRAMS = \
271 test_crypto_eddsa \ 272 test_crypto_eddsa \
272 test_crypto_ecdhe \ 273 test_crypto_ecdhe \
273 test_crypto_ecdh_eddsa \ 274 test_crypto_ecdh_eddsa \
275 test_crypto_ecc_dlog \
274 test_crypto_hash \ 276 test_crypto_hash \
275 test_crypto_hash_context \ 277 test_crypto_hash_context \
276 test_crypto_hkdf \ 278 test_crypto_hkdf \
@@ -421,6 +423,12 @@ test_crypto_eddsa_LDADD = \
421 libgnunetutil.la \ 423 libgnunetutil.la \
422 $(LIBGCRYPT_LIBS) 424 $(LIBGCRYPT_LIBS)
423 425
426test_crypto_ecc_dlog_SOURCES = \
427 test_crypto_ecc_dlog.c
428test_crypto_ecc_dlog_LDADD = \
429 libgnunetutil.la \
430 $(LIBGCRYPT_LIBS)
431
424test_crypto_ecdhe_SOURCES = \ 432test_crypto_ecdhe_SOURCES = \
425 test_crypto_ecdhe.c 433 test_crypto_ecdhe.c
426test_crypto_ecdhe_LDADD = \ 434test_crypto_ecdhe_LDADD = \