aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-09-19 08:40:49 +0000
committerChristian Grothoff <christian@grothoff.org>2016-09-19 08:40:49 +0000
commit08f1726b6552ac29830637e9f7be4d42e2ea4294 (patch)
tree093a456dd05228fa3c592285085aae25eaba1164 /src/util/Makefile.am
parent9f649cbc9454317228c4a4d3580de3a8f8f008a8 (diff)
downloadgnunet-08f1726b6552ac29830637e9f7be4d42e2ea4294.tar.gz
gnunet-08f1726b6552ac29830637e9f7be4d42e2ea4294.zip
-modifying tests to use new service MQ API, implementing more of service MQ API
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am20
1 files changed, 11 insertions, 9 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index b7e60022f..0172df67f 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -265,6 +265,7 @@ endif
265check_PROGRAMS = \ 265check_PROGRAMS = \
266 test_bio \ 266 test_bio \
267 test_client.nc \ 267 test_client.nc \
268 test_client_unix.nc \
268 $(SSH_USING_TESTS) \ 269 $(SSH_USING_TESTS) \
269 test_common_allocation \ 270 test_common_allocation \
270 test_common_endian \ 271 test_common_endian \
@@ -299,7 +300,6 @@ check_PROGRAMS = \
299 test_connection_timeout_no_connect.nc \ 300 test_connection_timeout_no_connect.nc \
300 test_connection_transmit_cancel.nc \ 301 test_connection_transmit_cancel.nc \
301 test_mq \ 302 test_mq \
302 test_mq_client.nc \
303 test_os_network \ 303 test_os_network \
304 test_peer \ 304 test_peer \
305 test_plugin \ 305 test_plugin \
@@ -325,18 +325,18 @@ check_PROGRAMS = \
325# Declare .nc (NO-CONCURRENCY) as a test extension so that we can impart 325# Declare .nc (NO-CONCURRENCY) as a test extension so that we can impart
326# sequential execution order for them 326# sequential execution order for them
327TEST_EXTENSIONS = .nc 327TEST_EXTENSIONS = .nc
328test_connection.log: test_client.log 328test_connection.log: test_client.log
329test_connection_addressing.log: test_connection.log 329test_connection_addressing.log: test_connection.log
330test_connection_timeout_no_connect.log: test_connection_addressing.log 330test_connection_timeout_no_connect.log: test_connection_addressing.log
331test_connection_transmit_cancel.log: test_connection_timeout_no_connect.log 331test_connection_transmit_cancel.log: test_connection_timeout_no_connect.log
332test_connection_receive_cancel.log: test_connection_transmit_cancel.log 332test_connection_receive_cancel.log: test_connection_transmit_cancel.log
333test_connection_timeout.log: test_connection_receive_cancel.log 333test_connection_timeout.log: test_connection_receive_cancel.log
334test_mq_client.log: test_connection_timeout.log 334test_resolver_api.log: test_connection_timeout.log
335test_resolver_api.log: test_mq_client.log
336test_server.log: test_resolver_api.log 335test_server.log: test_resolver_api.log
337test_server_disconnect.log: test_server.log 336test_server_disconnect.log: test_server.log
338test_server_with_client.log: test_server_disconnect.log 337test_server_with_client.log: test_server_disconnect.log
339test_server_mst_interrupt.log: test_server_with_client.log 338test_server_mst_interrupt.log: test_server_with_client.log
339test_client_unix.log: test_server_mst_interrupt.log
340 340
341test_bio_SOURCES = \ 341test_bio_SOURCES = \
342 test_bio.c 342 test_bio.c
@@ -357,6 +357,11 @@ test_client_nc_SOURCES = \
357test_client_nc_LDADD = \ 357test_client_nc_LDADD = \
358 libgnunetutil.la 358 libgnunetutil.la
359 359
360test_client_unix_nc_SOURCES = \
361 test_client.c
362test_client_unix_nc_LDADD = \
363 libgnunetutil.la
364
360test_socks_nc_SOURCES = \ 365test_socks_nc_SOURCES = \
361 test_socks.c 366 test_socks.c
362test_socks_nc_LDADD = \ 367test_socks_nc_LDADD = \
@@ -538,11 +543,6 @@ test_mq_SOURCES = \
538test_mq_LDADD = \ 543test_mq_LDADD = \
539 libgnunetutil.la 544 libgnunetutil.la
540 545
541test_mq_client_nc_SOURCES = \
542 test_mq_client.c
543test_mq_client_nc_LDADD = \
544 libgnunetutil.la
545
546test_os_network_SOURCES = \ 546test_os_network_SOURCES = \
547 test_os_network.c 547 test_os_network.c
548test_os_network_LDADD = \ 548test_os_network_LDADD = \
@@ -670,6 +670,8 @@ perf_malloc_LDADD = \
670 670
671 671
672EXTRA_DIST = \ 672EXTRA_DIST = \
673 test_client_data.conf \
674 test_client_unix.conf \
673 test_configuration_data.conf \ 675 test_configuration_data.conf \
674 test_program_data.conf \ 676 test_program_data.conf \
675 test_resolver_api_data.conf \ 677 test_resolver_api_data.conf \