aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 25 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 39e7ffa7e..bd92bd0e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,7 +21,7 @@
21# 21#
22AC_PREREQ(2.61) 22AC_PREREQ(2.61)
23# Checks for programs. 23# Checks for programs.
24AC_INIT([gnunet], [0.13.1], [bug-gnunet@gnu.org]) 24AC_INIT([gnunet], [0.13.2], [bug-gnunet@gnu.org])
25AC_CONFIG_AUX_DIR([build-aux]) 25AC_CONFIG_AUX_DIR([build-aux])
26 26
27# check for legacy option that is no longer supported (#5627) and fail hard 27# check for legacy option that is no longer supported (#5627) and fail hard
@@ -142,9 +142,11 @@ AS_CASE(["$host_os"],
142 UNIXONLY="#" 142 UNIXONLY="#"
143 ], 143 ],
144 [*openbsd*],[ 144 [*openbsd*],[
145 LIBS=`echo $LIBS | sed -e "s/-ldl//"` 145 # We need to explicitly link libc
146 LDFLAGS="$LDFLAGS -Wl,-lc"
147 # We also need to enable PIC
148 CFLAGS="-fPIC $CFLAGS"
146 build_target="openbsd" 149 build_target="openbsd"
147 use_openbsd_libtool=true
148 LIBPREFIX= 150 LIBPREFIX=
149 DLLDIR=lib 151 DLLDIR=lib
150 UNIXONLY="#" 152 UNIXONLY="#"
@@ -1404,12 +1406,11 @@ AS_IF([test "$mysql" = "true" -a "x$enable_mysql_version_check" = "xyes"],
1404 AC_MSG_CHECKING(mysql version) 1406 AC_MSG_CHECKING(mysql version)
1405 AC_COMPILE_IFELSE([AC_LANG_PROGRAM( 1407 AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
1406 [[ 1408 [[
1407 #include <mysql/mysql.h>]], 1409 #include <mysql/mysql_version.h>]],
1408 [[ 1410 [[
1409 #if (MYSQL_VERSION_ID < 40100) 1411 #if (MYSQL_VERSION_ID < 40100)
1410 #error needs at least version >= 4.1 1412 #error needs at least version >= 4.1
1411 #endif 1413 #endif
1412 int main () { return 0; }
1413 ]]) 1414 ]])
1414 ], 1415 ],
1415 [mysql=true], 1416 [mysql=true],
@@ -1423,6 +1424,21 @@ AS_IF([test "$mysql" = "true" -a "x$enable_mysql_version_check" = "xyes"],
1423 mysqlfail=false 1424 mysqlfail=false
1424 AC_MSG_RESULT(ok) 1425 AC_MSG_RESULT(ok)
1425 ]) 1426 ])
1427 AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
1428 [[
1429 #include <mysql/mysql_version.h>]],
1430 [[
1431 #if (MYSQL_VERSION_ID < 80000)
1432 #error needs at least version >= 4.1
1433 #endif
1434 ]])
1435 ],
1436 [mysql8=true],
1437 [mysql8=false])
1438 AS_IF([test x$mysql8 = xtrue],
1439 [
1440 AC_DEFINE([HAVE_MYSQL8],[1],[Have mysql8])
1441 ],[])
1426]) 1442])
1427 1443
1428AM_CONDITIONAL(HAVE_MYSQL, test x$mysql = xtrue) 1444AM_CONDITIONAL(HAVE_MYSQL, test x$mysql = xtrue)
@@ -1923,6 +1939,10 @@ src/scalarproduct/Makefile
1923src/scalarproduct/scalarproduct.conf 1939src/scalarproduct/scalarproduct.conf
1924src/set/Makefile 1940src/set/Makefile
1925src/set/set.conf 1941src/set/set.conf
1942src/seti/Makefile
1943src/seti/seti.conf
1944src/setu/Makefile
1945src/setu/setu.conf
1926src/sq/Makefile 1946src/sq/Makefile
1927src/statistics/Makefile 1947src/statistics/Makefile
1928src/statistics/statistics.conf 1948src/statistics/statistics.conf