aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7fb10cf32..57dcd36b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -775,6 +775,24 @@ AC_ARG_ENABLE([testruns],
775AC_MSG_RESULT($enable_test_run) 775AC_MSG_RESULT($enable_test_run)
776AM_CONDITIONAL([ENABLE_TEST_RUN], [test "x$enable_tests_run" = "xyes"]) 776AM_CONDITIONAL([ENABLE_TEST_RUN], [test "x$enable_tests_run" = "xyes"])
777 777
778
779# should monkey be used when running (certain) services?
780AC_MSG_CHECKING(whether to run with monkey)
781AC_ARG_ENABLE([monkey],
782 [AS_HELP_STRING([--enable-monkey], [enable running with monkey])],
783 [enable_monkey=${enableval}],
784 [enable_monkey=no])
785AC_MSG_RESULT($enable_monkey)
786AM_CONDITIONAL([ENABLE_MONKEY], [test "x$enable_monkey" = "xyes"])
787if test "x$enable_monkey" = "xyes"
788then
789 MONKEYPREFIX=""
790else
791 MONKEYPREFIX="monkey"
792fi
793AC_SUBST(MONKEYPREFIX)
794
795
778# should expensive tests be run? 796# should expensive tests be run?
779AC_MSG_CHECKING(whether to run expensive tests) 797AC_MSG_CHECKING(whether to run expensive tests)
780AC_ARG_ENABLE([expensivetests], 798AC_ARG_ENABLE([expensivetests],