aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 881262cbe..668ac7529 100644
--- a/configure.ac
+++ b/configure.ac
@@ -611,6 +611,22 @@ else
611 AC_DEFINE([DOCUMENTATION],[0],[Not building the documentation]) 611 AC_DEFINE([DOCUMENTATION],[0],[Not building the documentation])
612fi 612fi
613 613
614# should the build process be building only the documentation?
615AC_MSG_CHECKING(whether to build only documentation)
616AC_ARG_ENABLE([documentation-only],
617 [AS_HELP_STRING([--enable-documentation-only], [build only the documentation])],
618 [documentation_only=${enableval}],
619 [documentation_only=no])
620AC_MSG_RESULT($documentation_only)
621if test "x$documentation_only" = "xyes"
622then
623 AM_CONDITIONAL([DOCUMENTATION_ONLY],true)
624 AC_DEFINE([DOCUMENTATION_ONLY],[1],[Building only the documentation])
625else
626 AM_CONDITIONAL([DOCUMENTATION_ONLY],false)
627 AC_DEFINE([DOCUMENTATION_ONLY],[0],[Not building only the documentation])
628fi
629
614# should the build process be restricted to the code required 630# should the build process be restricted to the code required
615# for GNU Taler wallets? 631# for GNU Taler wallets?
616AC_MSG_CHECKING(whether to compile GNU Taler Wallet library ONLY) 632AC_MSG_CHECKING(whether to compile GNU Taler Wallet library ONLY)