aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a73df0cb3..efae64917 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1499,9 +1499,12 @@ AS_IF([test "x$png" = "x1"],
1499# against libcurl-gnutls directly, in which case we manually set it just to be 1499# against libcurl-gnutls directly, in which case we manually set it just to be
1500# sure curl-config is not linked against another curl. 1500# sure curl-config is not linked against another curl.
1501AS_IF([test "x$curl_gnutls" = "x0"], 1501AS_IF([test "x$curl_gnutls" = "x0"],
1502 [AC_CHECK_PROG([CURL_SSL_BACKEND], ["curl-config"], [m4_esyscmd_s(curl-config --ssl-backends)]) 1502 [AC_CHECK_PROG([CURLCONFIG_BINARY], [curl-config], [curl-config], [None])
1503 AS_IF([test "x$CURLCONFIG_BINARY" = "xNone"],
1504 AC_SUBST([CURL_SSL_BACKEND],["Unkown SSL backend"]),
1505 AC_SUBST([CURL_SSL_BACKEND],[`curl-config --ssl-backends`]))
1503 http_client="curl ($CURL_SSL_BACKEND)"], 1506 http_client="curl ($CURL_SSL_BACKEND)"],
1504 [http_client="curl (GnuTLS)"]) 1507 [http_client="curl-gnutls"])
1505 1508
1506# ifconfig 1509# ifconfig
1507AS_IF([test "x$IFCONFIG_BINARY" = "xfalse"], 1510AS_IF([test "x$IFCONFIG_BINARY" = "xfalse"],