aboutsummaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index df6bdc275..d5797adb4 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -45,3 +45,25 @@ check_PROGRAMS = \
45 45
46test_gnunet_prefix_SOURCES = \ 46test_gnunet_prefix_SOURCES = \
47 test_gnunet_prefix.c 47 test_gnunet_prefix.c
48
49pkghellodir= $(pkgdatadir)/hellos
50
51install-data-local:
52 $(mkinstalldirs) $(DESTDIR)$(pkghellodir)
53 @$(NORMAL_INSTALL)
54 for hello in $(srcdir)/hellos/*; do \
55 if test -f $$hello; then \
56 $(INSTALL_DATA) $$hello $(DESTDIR)$(pkghellodir)/ ; \
57 fi \
58 done
59
60dist-hook:
61 if test -d $(srcdir)/hellos; then \
62 mkdir -p $(distdir)/hellos; \
63 for hello in $(srcdir)/hellos/*; do \
64 if test -f $$hello; then \
65 cp -p $$hello $(distdir)/hellos; \
66 fi \
67 done \
68 fi
69