aboutsummaryrefslogtreecommitdiff
path: root/contrib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/Makefile.am')
-rw-r--r--contrib/Makefile.am49
1 files changed, 12 insertions, 37 deletions
diff --git a/contrib/Makefile.am b/contrib/Makefile.am
index d83fb8846..ff1d1fbbb 100644
--- a/contrib/Makefile.am
+++ b/contrib/Makefile.am
@@ -5,13 +5,7 @@ tap32dir = $(pkgdatadir)/openvpn-tap32/tapw32/
5 5
6tap64dir = $(pkgdatadir)/openvpn-tap32/tapw64/ 6tap64dir = $(pkgdatadir)/openvpn-tap32/tapw64/
7 7
8noinst_SCRIPTS = \ 8SUBDIRS = scripts
9 scripts/terminate.py \
10 scripts/pydiffer.py \
11 scripts/removetrailingwhitespace.py \
12 scripts/gnunet_pyexpect.py \
13 scripts/gnunet_janitor.py \
14 scripts/gnunet-chk.py
15 9
16dist_pkgdata_DATA = \ 10dist_pkgdata_DATA = \
17 gns/gns-bcd.html \ 11 gns/gns-bcd.html \
@@ -35,6 +29,10 @@ tap64_DATA = \
35 3rdparty/Windows/openvpn-tap32/tapw64/OemWin2k.inf 29 3rdparty/Windows/openvpn-tap32/tapw64/OemWin2k.inf
36endif 30endif
37 31
32INITD_FILES = \
33 services/openrc/gnunet.initd \
34 services/systemd/gnunet.service
35
38EXTRA_DIST = \ 36EXTRA_DIST = \
39 conf/colorit/colorit.conf \ 37 conf/colorit/colorit.conf \
40 conf/editors/eclipse/gnunet_codingstyle.xml \ 38 conf/editors/eclipse/gnunet_codingstyle.xml \
@@ -42,14 +40,6 @@ EXTRA_DIST = \
42 conf/gnunet/no_autostart_above_core.conf \ 40 conf/gnunet/no_autostart_above_core.conf \
43 conf/nss/nssswitch.conf \ 41 conf/nss/nssswitch.conf \
44 conf/wireshark/wireshark.lua \ 42 conf/wireshark/wireshark.lua \
45 scripts/coverage.sh \
46 scripts/terminate.py.in \
47 scripts/gnunet_pyexpect.py.in \
48 scripts/gnunet_janitor.py.in \
49 scripts/gnunet-chk.py.in \
50 scripts/gnunet-bugreport \
51 scripts/removetrailingwhitespace.py.in \
52 scripts/pydiffer.py.in \
53 packages/nix/default.nix \ 43 packages/nix/default.nix \
54 packages/nix/gnunet-dev.nix \ 44 packages/nix/gnunet-dev.nix \
55 3rdparty/Windows/openvpn-tap32/tapw32/tap0901.sys \ 45 3rdparty/Windows/openvpn-tap32/tapw32/tap0901.sys \
@@ -60,28 +50,8 @@ EXTRA_DIST = \
60 3rdparty/Windows/openvpn-tap32/tapw64/OemWin2k.inf \ 50 3rdparty/Windows/openvpn-tap32/tapw64/OemWin2k.inf \
61 3rdparty/Windows/openvpn-tap32/INSTALL \ 51 3rdparty/Windows/openvpn-tap32/INSTALL \
62 3rdparty/Windows/openvpn-tap32/tap32-signed-i386-2.1.zip \ 52 3rdparty/Windows/openvpn-tap32/tap32-signed-i386-2.1.zip \
63 3rdparty/Windows/openvpn-tap32/tap32-source-2.1.zip 53 3rdparty/Windows/openvpn-tap32/tap32-source-2.1.zip \
64 54 $(INITD_FILES)
65CLEANFILES = \
66 $(noinst_SCRIPTS)
67
68do_subst = $(SED) -e 's,[@]PYTHON[@],$(PYTHON),g'
69
70# Use SUFFIX Extension rules, they are more portable for every
71# implementation of 'make'.
72# You'll also run into the "'%' is a GNU make extension warning"
73# if you use this:
74#
75#%.py: %.py.in Makefile
76# $(do_subst) < $< > $@
77# chmod +x $@
78#
79# instead of this:
80SUFFIXES = .py.in .py
81
82.py.in.py:
83 $(do_subst) < $< > $@
84 chmod +x $@
85 55
86check_PROGRAMS = \ 56check_PROGRAMS = \
87 test_gnunet_prefix 57 test_gnunet_prefix
@@ -104,6 +74,7 @@ test_gnunet_prefix_LDADD = \
104 $(LIBLTDL) -lunistring $(XLIB) 74 $(LIBLTDL) -lunistring $(XLIB)
105 75
106pkghellodir= $(pkgdatadir)/hellos 76pkghellodir= $(pkgdatadir)/hellos
77pkginitddir= $(pkgdatadir)/services
107 78
108install-data-local: 79install-data-local:
109 $(mkinstalldirs) $(DESTDIR)$(pkghellodir) 80 $(mkinstalldirs) $(DESTDIR)$(pkghellodir)
@@ -114,6 +85,10 @@ install-data-local:
114 fi \ 85 fi \
115 done 86 done
116 install scripts/gnunet-bugreport $(DESTDIR)$(bindir)/gnunet-bugreport 87 install scripts/gnunet-bugreport $(DESTDIR)$(bindir)/gnunet-bugreport
88 mkdir -p $(DESTDIR)$(pkgdatadir)/services/openrc
89 mkdir -p $(DESTDIR)$(pkgdatadir)/services/systemd
90 install services/openrc/gnunet.initd $(DESTDIR)$(pkginitddir)/openrc/
91 install services/systemd/gnunet.service $(DESTDIR)$(pkginitddir)/systemd/
117 92
118dist-hook: 93dist-hook:
119 if test -d $(srcdir)/hellos; then \ 94 if test -d $(srcdir)/hellos; then \