aboutsummaryrefslogtreecommitdiff
path: root/contrib/scripts/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/scripts/Makefile.am')
-rw-r--r--contrib/scripts/Makefile.am64
1 files changed, 42 insertions, 22 deletions
diff --git a/contrib/scripts/Makefile.am b/contrib/scripts/Makefile.am
index bbb9e6d67..2d4f5584b 100644
--- a/contrib/scripts/Makefile.am
+++ b/contrib/scripts/Makefile.am
@@ -3,38 +3,58 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include
3 3
4SUBDIRS = gnunet-logread 4SUBDIRS = gnunet-logread
5 5
6noinst_SCRIPTS = \
7 terminate.py \
8 pydiffer.py \
9 removetrailingwhitespace.py \
10 gnunet_pyexpect.py \
11 gnunet_janitor.py \
12 gnunet-chk.py \
13 $(awkSCRIPTS)
14
15# FIXME: read into AWK_SCRIPTS autotools builtin. 6# FIXME: read into AWK_SCRIPTS autotools builtin.
16if HAVE_AWK 7if HAVE_AWK
17awkSCRIPTS = \ 8awkSCRIPTS = \
18 check-texinfo.awk 9 check-texinfo.awk
19else 10else
20awkSCRIPTS = 11awkSCRIPTS =
21endif 12endif
22 13
14noinst_SCRIPTS = \
15 terminate.py \
16 pydiffer.py \
17 removetrailingwhitespace.py \
18 gnunet_pyexpect.py \
19 gnunet_janitor.py \
20 gnunet-chk.py \
21 $(awkSCRIPTS)
22
23bin_SCRIPTS = \ 23bin_SCRIPTS = \
24 gnunet-bugreport \ 24 gnunet-bugreport \
25 gnunet-suidfix 25 gnunet-suidfix
26 26
27EXTRA_DIST = \ 27EXTRA_DIST = \
28 coverage.sh \ 28 coverage.sh \
29 terminate.py.in \ 29 terminate.py.in \
30 gnunet_pyexpect.py.in \ 30 gnunet_pyexpect.py.in \
31 gnunet_janitor.py.in \ 31 gnunet_janitor.py.in \
32 gnunet-chk.py.in \ 32 gnunet-chk.py.in \
33 $(SCRIPTS) \ 33 removetrailingwhitespace.py.in \
34 removetrailingwhitespace.py.in \ 34 pydiffer.py.in \
35 pydiffer.py.in \ 35 check-texinfo.awk.in \
36 gnunet-suidfix \ 36 build-install-gnunet-debian10.sh \
37 check-texinfo.awk.in 37 process_log.sh \
38 generate-monkey-db.sh \
39 find_typedefs.py \
40 pydmesg \
41 visualize_stats.sh \
42 changelog_delta.sh \
43 debug \
44 build_cscope.sh \
45 testbed_cleanup.sh \
46 lint/lint-man.sh \
47 lint/lint-python.sh \
48 revisionary.sh \
49 netjail/netjail_core.sh \
50 netjail/netjail_setup_internet.sh \
51 regression.sh \
52 doc/texinfo-hacks.el \
53 afferify \
54 zonewalk-to-types.sh \
55 gdb-iterate-dll.py \
56 $(SCRIPTS)
57
38 58
39CLEANFILES = \ 59CLEANFILES = \
40 $(noinst_SCRIPTS) 60 $(noinst_SCRIPTS)