aboutsummaryrefslogtreecommitdiff
path: root/doc/documentation/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/documentation/Makefile.am')
-rw-r--r--doc/documentation/Makefile.am227
1 files changed, 227 insertions, 0 deletions
diff --git a/doc/documentation/Makefile.am b/doc/documentation/Makefile.am
new file mode 100644
index 000000000..5bcf3d2a3
--- /dev/null
+++ b/doc/documentation/Makefile.am
@@ -0,0 +1,227 @@
1# This Makefile.am is in the public domain
2docdir = $(datadir)/doc/gnunet/
3
4infoimagedir = $(infodir)/images
5
6#DOT_FILES = images/$(wildcard *.dot)
7
8#DOT_VECTOR_GRAPHICS = \
9# $(DOT_FILES:%.dot=%.eps) \
10# $(DOT_FILES:%.dot=%.pdf)
11
12AM_MAKEINFOHTMLFLAGS = --no-split --css-ref=docstyle.css
13
14dist_infoimage_DATA = \
15 images/gnunet-gtk-0-10-gns-a-done.png \
16 images/gnunet-gtk-0-10-gns-a.png \
17 images/daemon_lego_block.png \
18 images/gnunet-gtk-0-10-gns.png \
19 images/gnunet-0-10-peerinfo.png \
20 images/gnunet-gtk-0-10-identity.png \
21 images/gnunet-fs-gtk-0-10-star-tab.png \
22 images/gnunet-gtk-0-10.png \
23 images/gnunet-gtk-0-10-download-area.png \
24 images/gnunet-gtk-0-10-search-selected.png \
25 images/gnunet-gtk-0-10-fs-menu.png \
26 images/gnunet-gtk-0-10-traffic.png \
27 images/gnunet-gtk-0-10-fs.png \
28 images/gnunet-namestore-gtk-phone.png \
29 images/gnunet-gtk-0-10-fs-publish-editing.png \
30 images/gnunet-namestore-gtk-vpn.png \
31 images/gnunet-gtk-0-10-fs-published.png \
32 images/gnunet-setup-exit.png \
33 images/gnunet-gtk-0-10-fs-publish.png \
34 images/iceweasel-preferences.png \
35 images/gnunet-gtk-0-10-fs-publish-select.png \
36 images/iceweasel-proxy.png \
37 images/gnunet-gtk-0-10-fs-publish-with-file_0.png \
38 images/service_lego_block.png \
39 images/gnunet-gtk-0-10-fs-publish-with-file.png \
40 images/service_stack.png \
41 images/gnunet-gtk-0-10-fs-search.png \
42 images/gnunet-tutorial-service.png \
43 images/gnunet-tutorial-system.png \
44 images/daemon_lego_block.svg \
45 images/lego_stack.svg \
46 images/service_lego_block.svg \
47 images/structure.dot
48
49# images/$(wildcard *.png) \
50# images/$(wildcard *.svg)
51# $(DOT_FILES:%.dot=%.png)
52
53#DOT_OPTIONS = \
54# -Gratio=.9 -Gnodesep=.005 -Granksep=.00005 \
55# -Nfontsite=9 -Nheight=.1 -Nwidth=.1
56
57# .dot.png:
58# $(AM_V_DOT)$(DOT) -Tpng $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"; \
59# mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
60
61# .dot.pdf:
62# $(AM_V_DOT)$(DOT) -Tpdf $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"; \
63# mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
64
65# .dot.eps:
66# $(AM_V_DOT)$(DOT) -Teps $(DOT_OPTIONS) < "$<" > "$(srcdir)/$@.tmp"; \
67# mv "$(srcdir)/$@.tmp" "$(srcdir)/$@"
68
69# .png.eps:
70# $(AM_V_GEN)convert "$<" "$@-tmp.eps"; \
71# mv "$@-tmp.eps" "$@"
72
73# pdf-local: $(DOT_FILES=%.dot=$(top_srcdir)/%.pdf)
74# info-local: $(DOT_FILES=%.dot=$(top_srcdir)/%.png)
75# ps-local: $(DOT_FILES=%.dot=$(top_srcdir)/%.eps) \
76# $(top_srcdir)/%D%/images/coreutils-size-map.eps
77# dvi-local: ps-local
78
79gnunet_tutorial_examples = \
80 001.c \
81 002.c \
82 003.c \
83 004.c \
84 005.c \
85 006.c \
86 007.c \
87 008.c \
88 009.c \
89 010.c \
90 011.c \
91 012.c \
92 013.c \
93 013.1.c \
94 014.c \
95 015.c \
96 016.c \
97 017.c \
98 018.c \
99 019.c \
100 020.c \
101 021.c \
102 022.c \
103 023.c \
104 024.c \
105 025.c \
106 026.c
107
108info_TEXINFOS = \
109 gnunet.texi \
110 gnunet-c-tutorial.texi
111
112gnunet_TEXINFOS = \
113 chapters/developer.texi \
114 chapters/installation.texi \
115 chapters/philosophy.texi \
116 chapters/user.texi \
117 chapters/vocabulary.texi \
118 chapters/configuration.texi \
119 fdl-1.3.texi \
120 gpl-3.0.texi
121
122EXTRA_DIST = \
123 $(gnunet_TEXINFOS) \
124 $(gnunet_tutorial_examples) \
125 htmlxref.cnf \
126 run-gendocs.sh \
127 docstyle.css
128
129
130# $(DOT_FILES) \
131# $(DOT_VECTOR_GRAPHICS)
132
133DISTCLEANFILES = \
134 gnunet.cps \
135 gnunet-c-tutorial.cps \
136 chapters/developer.cps \
137 chapters/installation.cps \
138 chapter/philosophy.cps \
139 chapters/user.cps \
140 chapters/configuration.cps \
141 chapters/vocabulary.cps \
142 fdl-1.3.cps \
143 gpl-3.0.cps
144
145# if HAVE_EXTENDED_DOCUMENTATION_BUILDING
146daemon_lego_block.png: images/daemon_lego_block.svg
147 convert images/daemon_lego_block.svg images/daemon_lego_block.png &&
148 pngcrush images/daemon_lego_block.png images/daemon_lego_block.png
149
150service_lego_block.png: images/service_lego_block.svg
151 convert images/service_lego_block.svg images/service_lego_block.png &&
152 pngcrush images/service_lego_block.png images/serivce_lego_block.png
153
154lego_stack.png: images/lego_stack.svg
155 convert images/lego_stack.svg images/lego_stack.png &&
156 pngcrush images/lego_stack.png images/lego_stack.png
157
158# FIXME: The usage of 'date' strings causes a warning.
159# version.texi:
160# echo "@set UPDATED $(date +'%d %B %Y')" > $@
161# echo "@set UPDATED-MONTH $(date +'%B %Y')" >> $@
162# echo "@set EDITION $(PACKAGE_VERSION)" >> $@
163# echo "@set VERSION $(PACKAGE_VERSION)" >> $@
164
165# Workaround for makeinfo error. Whcih in turn introduces more
166# date-related 'warnings'. Well.
167version2.texi:
168 echo "@set UPDATED $(date +'%d %B %Y')" > $@
169 echo "@set UPDATED-MONTH $(date +'%B %Y')" >> $@
170 echo "@set EDITION $(PACKAGE_VERSION)" >> $@
171 echo "@set VERSION $(PACKAGE_VERSION)" >> $@
172
173# FIXME: rm *.html and *.pdf
174#doc-clean:
175# @rm *.aux *.log *.toc *.cp *.cps
176
177doc-all-install:
178 @mkdir -p $(DESTDIR)/$(docdir)
179 @mkdir -p $(DESTDIR)/$(infoimagedir)
180 @mkdir -p $(DESTDIR)/$(infodir)
181 @install -m 0755 gnunet.pdf $(DESTDIR)/$(docdir)
182 @install -m 0755 gnunet-c-tutorial.pdf $(DESTDIR)/$(docdir)
183 @install -m 0755 gnunet-c-tutorial.info $(DESTDIR)/$(infodir)
184 @install -m 0755 gnunet.info $(DESTDIR)/$(infodir)
185 @install gnunet.html $(DESTDIR)/$(docdir)
186 @install gnunet-c-tutorial.html $(DESTDIR)/$(docdir)
187
188# @cp -r images $(DESTDIR)/$(infoimagedir)
189
190dev-build: version.texi version2.texi
191 @makeinfo --pdf gnunet.texi
192 @makeinfo --pdf gnunet-c-tutorial.texi
193 @makeinfo --html gnunet.texi
194 @makeinfo --html gnunet-c-tutorial.texi
195 @makeinfo --no-split gnunet.texi
196 @makeinfo --no-split gnunet-c-tutorial.texi
197
198# TODO: Add more to clean.
199clean:
200 @rm gnunet.pdf
201 @rm gnunet.html
202 @rm gnunet.info
203 @rm gnunet.info-1
204 @rm gnunet.info-2
205 @rm gnunet.info-3
206 @rm gnunet-c-tutorial.pdf
207 @rm gnunet-c-tutorial.info
208 @rm gnunet-c-tutorial.html
209 @rm -r gnunet.t2p
210 @rm -r gnunet-c-tutorial.t2p
211
212# CLEANFILES = \
213# gnunet.log \
214# gnunet-c-tutorial.log \
215# $(wildcard *.aux) \
216# $(wildcard *.toc) \
217# $(wildcard *.cp) \
218# $(wildcard *.cps)
219
220#.PHONY: version.texi
221# if HAVE_EXTENDED_DOCUMENTATION_BUILDING_PDF
222
223# if HAVE_EXTENDED_DOCUMENTATION_BUILDING_HTML
224
225# endif
226# endif
227# endif