aboutsummaryrefslogtreecommitdiff
path: root/doc/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/man/Makefile.am')
-rw-r--r--doc/man/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/doc/man/Makefile.am b/doc/man/Makefile.am
index e60d11413..69e42bc9d 100644
--- a/doc/man/Makefile.am
+++ b/doc/man/Makefile.am
@@ -5,6 +5,8 @@ do_subst = $(SED) -e 's,[@]SYSCONFDIR[@],$(sysconfdir),g'
5gnunet.conf.5: gnunet.conf.5.in Makefile 5gnunet.conf.5: gnunet.conf.5.in Makefile
6 $(do_subst) < $(srcdir)/gnunet.conf.5.in > gnunet.conf.5 6 $(do_subst) < $(srcdir)/gnunet.conf.5.in > gnunet.conf.5
7 7
8do_subst_pkgdatadir = $(SED) -e 's,[@]pkgdatadir[@],$(pkgdatadir),g'
9
8CLEANFILES = gnunet.conf.5 10CLEANFILES = gnunet.conf.5
9 11
10if TEXI2MDOC_GENERATION 12if TEXI2MDOC_GENERATION
@@ -25,8 +27,13 @@ if HAVE_MANDOC
25# that this is the most portable way to achieve what 27# that this is the most portable way to achieve what
26# I want and that the alternatives are depressing and 28# I want and that the alternatives are depressing and
27# nonfunctional. 29# nonfunctional.
30produce_html.sh: produce_html.sh.in Makefile
31 $(do_subst_pkgdatadir) < $(srcdir)/produce_html.sh.in > produce_html.sh
32
33CLEANFILES += produce_html.sh
34
28.PHONY: man-html 35.PHONY: man-html
29man-html: 36man-html: produce_html.sh
30 $(SH) $(srcdir)/produce_html.sh 37 $(SH) $(srcdir)/produce_html.sh
31 38
32htmldocdir = $(datadir)/doc/gnunet/manhtml/ 39htmldocdir = $(datadir)/doc/gnunet/manhtml/
@@ -96,4 +103,5 @@ endif
96 103
97EXTRA_DIST = ${man_MANS} \ 104EXTRA_DIST = ${man_MANS} \
98 gnunet.conf.5.in \ 105 gnunet.conf.5.in \
106 produce_html.sh.in \
99 README 107 README