aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 09d176100..1bcc1ae7b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -24,13 +24,15 @@ endif
24endif 24endif
25 25
26if HAVE_JSON 26if HAVE_JSON
27if HAVE_MHD
27 JSON_DIR = json 28 JSON_DIR = json
29endif
30endif
28if HAVE_LIBGNURL 31if HAVE_LIBGNURL
29 JSON_DIR += curl 32 CURL_DIR = curl
30else 33else
31if HAVE_LIBCURL 34if HAVE_LIBCURL
32 JSON_DIR += curl 35 CURL_DIR = curl
33endif
34endif 36endif
35endif 37endif
36 38
@@ -81,6 +83,7 @@ SUBDIRS = \
81 arm \ 83 arm \
82 $(TESTING) \ 84 $(TESTING) \
83 $(JSON_DIR) \ 85 $(JSON_DIR) \
86 $(CURL_DIR) \
84 $(REST_DIR) \ 87 $(REST_DIR) \
85 peerinfo \ 88 peerinfo \
86 $(SQLITE_DIR) \ 89 $(SQLITE_DIR) \