aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index edfbb6922..47d6896cb 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -21,14 +21,18 @@ if HAVE_EXPERIMENTAL
21 psyc \ 21 psyc \
22 rps \ 22 rps \
23 social \ 23 social \
24 $(CONSENSUS) \ 24 $(CONSENSUS) \
25 $(SECRETSHARING) \ 25 $(SECRETSHARING) \
26 $(SENSOR) \ 26 $(SENSOR) \
27 $(SENSORDASHBOARD) 27 $(SENSORDASHBOARD)
28endif 28endif
29 29
30if HAVE_REST 30if HAVE_REST
31 EXP_DIR += identity-provider 31 PROVIDER_DIR = identity-provider
32endif
33
34if HAVE_JSON
35 JSON_DIR = json
32endif 36endif
33 37
34if BUILD_PULSE_HELPERS 38if BUILD_PULSE_HELPERS
@@ -60,7 +64,8 @@ else
60SUBDIRS = \ 64SUBDIRS = \
61 include $(INTLEMU_SUBDIRS) \ 65 include $(INTLEMU_SUBDIRS) \
62 util \ 66 util \
63 $(REST_DIR) \ 67 $(JSON_DIR) \
68 $(REST_DIR) \
64 hello \ 69 hello \
65 tun \ 70 tun \
66 block \ 71 block \
@@ -104,6 +109,7 @@ SUBDIRS = \
104 exit \ 109 exit \
105 pt \ 110 pt \
106 integration-tests \ 111 integration-tests \
107 $(EXP_DIR) 112 $(EXP_DIR) \
113 $(PROVIDER_DIR)
108 114
109endif 115endif