aboutsummaryrefslogtreecommitdiff
path: root/src/ats/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/ats/Makefile.am')
-rw-r--r--src/ats/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/ats/Makefile.am b/src/ats/Makefile.am
index 1f8a84a67..5b7e9a127 100644
--- a/src/ats/Makefile.am
+++ b/src/ats/Makefile.am
@@ -17,6 +17,7 @@ if HAVE_LIBGLPK
17 GN_LIBGLPK = -lglpk 17 GN_LIBGLPK = -lglpk
18 GN_MLP_SRC = gnunet-service-ats_addresses_mlp.c gnunet-service-ats_addresses_mlp.h 18 GN_MLP_SRC = gnunet-service-ats_addresses_mlp.c gnunet-service-ats_addresses_mlp.h
19 GN_MLP_TEST = test_ats_mlp 19 GN_MLP_TEST = test_ats_mlp
20 GN_MLP_PERF = perf_ats_mlp
20endif 21endif
21 22
22lib_LTLIBRARIES = libgnunetats.la 23lib_LTLIBRARIES = libgnunetats.la
@@ -52,7 +53,8 @@ gnunet_service_ats_LDADD = \
52 53
53check_PROGRAMS = \ 54check_PROGRAMS = \
54 test_ats_api_scheduling \ 55 test_ats_api_scheduling \
55 $(GN_MLP_TEST) 56 $(GN_MLP_TEST) \
57 $(GN_MLP_PERF)
56# test_ats_api_scheduling_get_type 58# test_ats_api_scheduling_get_type
57# test_ats_api_bandwidth_consumption 59# test_ats_api_bandwidth_consumption
58 60
@@ -68,6 +70,14 @@ test_ats_mlp_LDADD = \
68 $(GN_LIBGLPK) \ 70 $(GN_LIBGLPK) \
69 $(top_builddir)/src/util/libgnunetutil.la \ 71 $(top_builddir)/src/util/libgnunetutil.la \
70 $(top_builddir)/src/statistics/libgnunetstatistics.la 72 $(top_builddir)/src/statistics/libgnunetstatistics.la
73
74perf_ats_mlp_SOURCES = \
75 $(GN_MLP_SRC) \
76 perf_ats_mlp.c
77perf_ats_mlp_LDADD = \
78 $(GN_LIBGLPK) \
79 $(top_builddir)/src/util/libgnunetutil.la \
80 $(top_builddir)/src/statistics/libgnunetstatistics.la
71endif 81endif
72 82
73test_ats_api_scheduling_SOURCES = \ 83test_ats_api_scheduling_SOURCES = \